Some web pages generate hundreds of pages to the printer or print preview.

RESOLVED DUPLICATE of bug 212984

Status

()

RESOLVED DUPLICATE of bug 212984
15 years ago
15 years ago

People

(Reporter: ghg22, Assigned: bugzilla)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.7

Printing the above-mentioned web pages generated hundreds of pages.

Reproducible: Always
Steps to Reproduce:
1. Go to web page specified using Firebird.
2. Click Print.
3.

Actual Results:  
Wasted hundreds of pieces of paper.
Got yelled at by other people in office.

Expected Results:  
Print correctly.

Comment 1

15 years ago
Hi Gerald, it works fine for me on Windows XP, using 20040120 Firebird/0.7+.
So one possibility is that it's your old version of Firebird. You could try a
more recent nightly build from http://www.mozilla.org/developer/

You say it prints hundreds of pages, but what is on them?

If you go to print preview, how many pages does it display?

I assume it'll print other pages with no problems?

Have you tried to reproduce this, or did you only try it once?

cheers, Wayne

Comment 2

15 years ago
Hi Gerald, are you still reading mail for this bug? If so, is printing in
Firefox working properly now?

If I don't hear back, I'll resolve this as WORKSFORME.

Comment 3

15 years ago
By the way, if you are still reading mail for this bug, please don't reply by
email. Apparently emails sent to the daemon vanish without anyone knowing you'd
tried to post anything. Please follow the bug link and report it in the
Additional Comments box :)

Comment 4

15 years ago
This happens also at:

http://www.msnbc.msn.com/id/4516529/

Mine turned this 7 or 8 page article into 295 pages.  If only I could do that
with my bank account... Anyway, the first page contains a few images from the
page, and then the next hundred or so pages contain either a short sporadically
dashed horizontal line of one pixel height and maybe two inches long or a couple
of words from the page to be printed.  Further into the forest of trees that was
used up in printing this, some of the other page images begun to appear along
with a few more of the words.  Toward the end, most of the article finally
started to appear together.  

Preview mode accurately depicts the mess that is soon to appear on the more than
half a ream of paper should one be foolish enough to actually attempt to print
it after seeing the mangled excuse for a rendering on his or her screen.

Needless to say, I had no choice but to remember where the seldom-used MSIE
shortcut resides so that I could print a usable copy of this page.  I've had a
few other instances of poorly rendered print jobs using Seamonkey and
Phoenix/Firebird/Firefox, but fortunately it renders more correctly than not. 
Let's try to get these kinds of visible issues resolved so that the browser
doesn't look stupid to the fence sitter when the marketing campaign eventually
kicks off.

FYI, this is a Windows XP SP1 system using Firefox nightly 20040321, attempting
to print to an HP 4100.

Comment 5

15 years ago
While I still can't reproduce the bug with the original test URL (maybe the
website was changed), I can definitely reproduce it with Chris's new URL.

This bug occurs with the standard Mozilla browser as well, and is already known
- bug 212984.

*** This bug has been marked as a duplicate of 212984 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Component: General → Printing
Product: Firefox → Browser
Resolution: --- → DUPLICATE
Summary: Printing an interview with Bruce Perens generated hundreds of pages to the printer. → Some web pages generate hundreds of pages to the printer or print preview.
Version: unspecified → Trunk
You need to log in before you can comment on or make changes to this bug.