Javascript console under Tools freezes machine.

VERIFIED WONTFIX

Status

()

P1
critical
VERIFIED WONTFIX
20 years ago
17 years ago

People

(Reporter: object01, Assigned: brendan)

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

20 years ago
Appears to be 100% reproducible, regardless of the circumstances.  Attempting to
access the Javascript console immediately froze my machine.

Updated

20 years ago
Status: NEW → ASSIGNED

Comment 1

20 years ago
I can't seem to reproduce this.  (I tried with a very recent (today) build, in a
Windows NT machine.)

I notice that the bug version field has the 1998-03-31 version set; is this the
version under which you noticed the bug?  If so, does it occur for you under a
more recent version of the browser?  The source code for the browser has
undergone sweeping changes since then, and it's very likely that this has been
fixed.

Mike

Comment 2

20 years ago
Setting all current Open Critical and Major to M3

Comment 3

20 years ago
per leger, assigning QA contacts to all open bugs without QA contacts according
to list at http://bugzilla.mozilla.org/describecomponents.cgi?product=Browser

Comment 4

20 years ago
DOM bugs are not my problem.

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → INVALID

Comment 5

20 years ago
I just gave this a try (seamonkey viewer, in windows NT; apprunner doesn't seem
to _have_ a javascript console) ... and everything works for me.  Even seems to
be a little more full-featured than the old javascript console.

Could this bug have been against mozilla classic?

Marking as invalid (not against current codebase)

Updated

20 years ago
QA Contact: 4015 → 4616

Comment 6

20 years ago
QA contact re-assigned according to the product areas we're currently working
on.

Updated

20 years ago
Status: RESOLVED → REOPENED
Summary: Javascript console freezes machine → Javascript console under Tools freezes machine.

Comment 7

20 years ago
It seems this bug is still there, and seems to be 100% reproducible.
Providing the specs for reproducing the bug.
Product: Viewer.exe
Build: 03/17/99
Platform: PC
OS: Windows-95

I tried to click Javascript console 3 times with the specs specified above, and
it freezes machine everytime. It just freezes everything.
For reproducing this bug, please follow all the specifications I specified
above. Operating system should ve Windows-95. Open Viewer [Not app-runner] and
there is one menu called "Tools", click that menu and under "Tools" there is
menu called "JavaScript Console", click this menu. As soon as you click this
menu, it freezes the system.

Updated

20 years ago
Target Milestone: M3 → M4

Comment 8

20 years ago
move to m4.  we should turn this off or fix this. its a pretty hard crash..

Updated

20 years ago
Assignee: mccabe → joki
Status: REOPENED → NEW

Comment 9

20 years ago
Reassigning to joki; he claims it's a dup.

Updated

20 years ago
Resolution: INVALID → ---

Updated

20 years ago
Target Milestone: M4 → M5

Comment 10

20 years ago
This is kind of serious but since the JS console only lives in viewer, not in
apprunner I don't think it'll be a big problem to go with M4 without this.
Moving to M5

Updated

20 years ago
Target Milestone: M5 → M6

Updated

20 years ago
Assignee: joki → brendan
Target Milestone: M6 → M7

Comment 11

20 years ago
Brendan I'm going to throw this to you on the off chance you have time to look
at it.  If I get time later I'll take it back but if you're messing with
console stuff you'll have a better shot at it.
(Assignee)

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago20 years ago
Resolution: --- → WONTFIX

Comment 12

20 years ago
JS console on Win95 viewer is too marginal, considering what we've got to do to
finish the separate Mozilla 5.0 program.  I'm marking WONTFIX, if someone wants
it fixed they'll have to do it themselves.

/be

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 13

20 years ago
Marking as verified.

Comment 14

20 years ago
Changing component to "Javascript Engine".  "Javascript" component is being
retired.
You need to log in before you can comment on or make changes to this bug.