Second Search>Search the Internet clobbers the first; unusable

VERIFIED FIXED in M14

Status

SeaMonkey
UI Design
P1
critical
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: Sean Richardson, Assigned: Bill Law)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: waiting for 23493 fix in order to verify)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
* Overview:
If another Search window is opened by selecting one of the four menu items
in the second section on the Search menu, the existing Search dialog is
replaced by one that is blank and unusable, clobbering the earlier one.
The user may still have been wanting to get back to it...

* Steps to Reproduce:
1. Select the Search>Search the Internet menu item.
2. Do a quick search.
3. Go back to the Search menu and select any of the four items in the second
   section.

* Actual results:
The Search dialog used in step 2 will disappear in step 3, and be replaced
by a Search dialog of the same size that does not render any of its contents
beyond the tabs for the four kinds of searching, and is thus useless.
(After closing this another will come up normally).

* Expected Results:
One of the following:
A. A second, completely independent Search dialog will appear, and nothing will
   happen to the previous one.
B. The previous Search dialog will be made visible and given focus; if a
   different type of search is chosen than previously, the tab will change
   but the state of the tab used in step 2 will be maintained until the
   dialog is closed. (Similar to what is seen if Tasks>Composer is selected
   twice).

* Tested with:
2000-01-05-08-M13 nightly binary on Windows NT 4.0sp3.

Updated

18 years ago
QA Contact: paulmac → claudius

Comment 1

18 years ago
setting claudius as QA contact for this and cc:ing rjc.

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 2

18 years ago
Fixed.

Updated

18 years ago
Status: RESOLVED → REOPENED
Summary: Second Search>Search the Internet clobbers the first; unusable → [CRASH]Second Search>Search the Internet clobbers the first; unusable

Comment 3

18 years ago
Ummm, no. All I had to do was select Search|Search the internet once and then go back and try again for the fun to start.
You don't even have to actually do an original search.
To Repro:
1. Select Search| Search the Internet.
2. Select Search| Search Bookmarks/History.
3. Buh-bye.

I've repro'd this on all three platforms with today's builds.

	Selecting Search the Internet again in step 2 yields strange results per platform. on linux, I quit silently. On WinNT I hung
for a while until I got an OS out of memory dialog and then quit silently. On mac the first search dialog came to front.

MacsBug trace as soon as my Mac reboots :-(

Comment 4

18 years ago
Created attachment 4182 [details]
the full MacsBug trace for aforementioned crash

Comment 5

18 years ago
The crash you are seeing is a different problem that the original bug.

Don, you might want to point this bug at either hyatt or waterson for starters.

Updated

18 years ago
Resolution: FIXED → ---

Comment 6

18 years ago
Clearing FIXED resolution due to reopen.

Updated

18 years ago
Severity: normal → critical

Comment 7

18 years ago
*** Bug 23801 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Assignee: don → law
Status: REOPENED → NEW
Priority: P3 → P1
Target Milestone: M14

Comment 8

18 years ago
Hmmm, I wonder if this is related to bug #23029 (Two Find on this page crashes
Mozilla)?  Bill, is this yet another XPToolkit problem?

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
Summary: [CRASH]Second Search>Search the Internet clobbers the first; unusable → Second Search>Search the Internet clobbers the first; unusable
Whiteboard: waiting for 23493 fix in order to verify

Comment 9

18 years ago
The original version of the bug has been fixed. The current crashing symptoms can
be tracked via bug 23493. This one will be resolved/fixed and verification will wait on
the fix for bug 23493

Comment 10

18 years ago
VERIFIED fixed with 2000020108 build
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.