Bugs that I report give me the option to assign an owner, but don't let me actually change it.

RESOLVED DUPLICATE of bug 95923

Status

()

RESOLVED DUPLICATE of bug 95923
15 years ago
5 years ago

People

(Reporter: jtalkington, Assigned: myk)

Tracking

Details

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7a) Gecko/20040130 Firebird/0.8.0+

I filed a bug that I would like assigned to me, but when I click on "Change the
owner to:" and enter my email address, I get an error.
---
 You tried to change the Status field from UNCONFIRMED to NEW, but only the
owner or submitter of the bug, or a sufficiently empowered user, may change that
field. 
--


Reproducible: Always
Steps to Reproduce:
1. Create a new bug.
2. Try to change the owner (using an account that does not have permissions to
change bug status)
3. See the error.

Actual Results:  
Big Red Box:
 You tried to change the Status field from UNCONFIRMED to NEW, but only the
owner or submitter of the bug, or a sufficiently empowered user, may change that
field. 

Expected Results:  
Either the option to change the owner should not appear, or it should work.
I've seen people run into this....
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

14 years ago
Bugzilla does *NOT* allow the reporter to *reassign* its bugs, unless it has
editbugs privs. What you can do is to *assign* the bug to you when *creating*
the bug. You can then change your mind and reassign it to someone else, because
as the assignee, which gives you some additional rights, you are then allowed to
do that change. But as soon as you have reassigned your bug to someone else, you
lose your additional rights (you are not the assignee anymore!) and you come
back to the status of a reporter without the rights to reassign. #

Clear enough? :)
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
I don't think this is invalid...  I do think, on the other hand, that it's a
duplicate of the bug to get the bug change form to only show you form controls
for the fields you're actually allowed to change, but I'm not sure where that
bug is off-hand.  (my first couple searches aren't finding it, but I know I've
seen it)
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Whiteboard: DUPEME

Comment 4

14 years ago
OK, so let's mark it as a dupe of bug 95923.... :)

*** This bug has been marked as a duplicate of 95923 ***
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → DUPLICATE
QA Contact: matty_is_a_geek → default-qa

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.