Crash in layout gdk_draw_pixmap

RESOLVED DUPLICATE of bug 231768

Status

Core Graveyard
GFX: Gtk
--
critical
RESOLVED DUPLICATE of bug 231768
14 years ago
9 years ago

People

(Reporter: Aaron Williams, Assigned: Roland Mainz)

Tracking

Trunk
Sun
Solaris

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.6) Gecko/20040116

Mozilla crashes when I attempt to view http://www.opennms.org

I am running this on Solaris 2.8 with fairly recent patches.

uname -a
SunOS starbug 5.8 Generic_108528-22 sun4u sparc SUNW,Sun-Blade-100


Reproducible: Always
Steps to Reproduce:
1. Go to www.opennms.org
2. Watch Mozilla crash


Actual Results:  
Mozilla crashed

Expected Results:  
I should be able to view the page

#0  0xfe3c79a8 in gdk_draw_pixmap (drawable=0x19e68a8, gc=0x3, src=0x1ade958,
    xsrc=1, ysrc=0, xdest=1, ydest=3, width=1, height=74) at gdkdraw.c:394
#1  0xfd68c0a8 in NSGetModule () from /opt/Mozilla/1.6/components/libgfx_gtk.so
#2  0xfd68beb4 in NSGetModule () from /opt/Mozilla/1.6/components/libgfx_gtk.so
#3  0xfd68cb60 in NSGetModule () from /opt/Mozilla/1.6/components/libgfx_gtk.so
#4  0xfd6b0f18 in NSGetModule () from /opt/Mozilla/1.6/components/libgfx_gtk.so
#5  0xfcd21d0c in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
#6  0xfcd02380 in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
#7  0xfcd02248 in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
#8  0xfcd1840c in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
#9  0xfcd2a9a4 in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
#10 0xfcd02380 in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
#11 0xfccf8f34 in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
#12 0xfcd1840c in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
---Type <return> to continue, or q <return> to quit---
#13 0xfccf8cb0 in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
#14 0xfcd02380 in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
#15 0xfcd02248 in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
#16 0xfcddd1b8 in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
#17 0xfcd02380 in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
#18 0xfcd02248 in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
#19 0xfcdf9a04 in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
#20 0xfcdfc35c in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
#21 0xfcdfc210 in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
#22 0xfcd02380 in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
#23 0xfcd02248 in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
---Type <return> to continue, or q <return> to quit---
#24 0xfcde425c in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
#25 0xfcde439c in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
#26 0xfcd02380 in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
#27 0xfcdf4478 in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
#28 0xfcd02380 in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
#29 0xfccf8f34 in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
#30 0xfcd1840c in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
#31 0xfccf8cb0 in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
#32 0xfcd02380 in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
#33 0xfcd02248 in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
#34 0xfcddd1b8 in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
---Type <return> to continue, or q <return> to quit---
#35 0xfcd02380 in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
#36 0xfcd02248 in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
#37 0xfcdf9a04 in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
#38 0xfcdfc35c in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
#39 0xfcdfc210 in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
#40 0xfcd02380 in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
#41 0xfcd02248 in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
#42 0xfcde425c in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
#43 0xfcde439c in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
#44 0xfcd02380 in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
#45 0xfcdf4478 in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
---Type <return> to continue, or q <return> to quit---
#46 0xfcd02380 in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
#47 0xfccf8f34 in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
#48 0xfcd1840c in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
#49 0xfccf8cb0 in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
#50 0xfcd02380 in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
#51 0xfccf8f34 in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
#52 0xfcd1840c in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
#53 0xfccf8cb0 in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
#54 0xfcd02380 in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
#55 0xfcd02248 in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
#56 0xfcd18288 in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
---Type <return> to continue, or q <return> to quit---
#57 0xfcd19774 in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
#58 0xfcd50cf8 in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
#59 0xfd0ed494 in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
#60 0xfd0f3f08 in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
#61 0xfd0f3b0c in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
#62 0xfd0f2440 in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
#63 0xfd0f50b8 in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
#64 0xfd0ecc80 in NSGetModule ()
   from /opt/Mozilla/1.6/components/libgklayout.so
#65 0xfd4b4418 in _edata () from /opt/Mozilla/1.6/components/libwidget_gtk.so
#66 0xfd4b42fc in _edata () from /opt/Mozilla/1.6/components/libwidget_gtk.so
#67 0xfd4b8038 in NSGetModule ()
   from /opt/Mozilla/1.6/components/libwidget_gtk.so
#68 0xfd4b8178 in NSGetModule ()
   from /opt/Mozilla/1.6/components/libwidget_gtk.so
---Type <return> to continue, or q <return> to quit---
#69 0xfd4b7e30 in NSGetModule ()
   from /opt/Mozilla/1.6/components/libwidget_gtk.so
#70 0xfe7d6f14 in g_idle_dispatch (source_data=0xfd4b7db4,
    dispatch_time=0xffbede40, user_data=0xfd4ef388) at gmain.c:1367
#71 0xfe7d5934 in g_main_dispatch (dispatch_time=0xffbede40) at gmain.c:656
#72 0xfe7d6044 in g_main_iterate (block=-25183864, dispatch=1) at gmain.c:877
#73 0xfe7d6348 in g_main_run (loop=0x39aaa8) at gmain.c:935
#74 0xfe5bd7f0 in gtk_main () at gtkmain.c:524
#75 0xfd4a1284 in _edata () from /opt/Mozilla/1.6/components/libwidget_gtk.so
#76 0x00022f1c in __1cKgetCountry6FrknJnsAString_r0_I_ ()
#77 0x00023984 in main ()
(Assignee)

Updated

14 years ago
OS: SunOS → Solaris
.
Assignee: general → blizzard
Component: Browser-General → GFX: Gtk
QA Contact: general → ian
bug pong!
Assignee: blizzard → tor

Comment 3

14 years ago
bug pong!
Assignee: tor → Roland.Mainz
(Assignee)

Comment 4

14 years ago
This seems to be the same as bug 231768 ...

*** This bug has been marked as a duplicate of 231768 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.