In <FilterEditor.js>, "Warning: assignment to undeclared variable targetUri"

RESOLVED FIXED in mozilla1.8alpha2

Status

MailNews Core
Filters
--
minor
RESOLVED FIXED
14 years ago
10 years ago

People

(Reporter: sgautherie, Assigned: sgautherie)

Tracking

({fixed1.7.5})

Trunk
mozilla1.8alpha2
fixed1.7.5

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Assignee)

Description

14 years ago
[Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.6) Gecko/20040113] (W98SE)

{
Warning: assignment to undeclared variable targetUri
Source File: chrome://messenger/content/FilterEditor.js
Line: 416
}

Reproductible: 100%
1. MailNews > Tools > Message Filters...
2. Edit > Move to folder (change the destination) > OK
(Assignee)

Comment 1

14 years ago
Created attachment 140623 [details] [diff] [review]
(Av1) <FilterEditor.js>

Bug fix, plus |var str| removal.
Assignee: sspitzer → gautheri
Status: NEW → ASSIGNED
(Assignee)

Updated

14 years ago
Attachment #140623 - Flags: review?(neil.parkwaycc.co.uk)

Comment 2

14 years ago
Comment on attachment 140623 [details] [diff] [review]
(Av1) <FilterEditor.js>

Sorry, I can't give + to patches that use window.alert - either don't remove
var str, or change it to use the prompt service.
Attachment #140623 - Flags: review?(neil.parkwaycc.co.uk) → review-
(Assignee)

Updated

14 years ago
Attachment #140623 - Attachment is obsolete: true
(Assignee)

Comment 3

14 years ago
Created attachment 140769 [details] [diff] [review]
(Av2) <FilterEditor.js>

Av1, with comment 2 suggestion(s).
(Assignee)

Comment 4

14 years ago
Comment on attachment 140769 [details] [diff] [review]
(Av2) <FilterEditor.js>


I copied and adapted |GetPromptService()| from an LXR search...
Attachment #140769 - Flags: review?(neil.parkwaycc.co.uk)

Comment 5

14 years ago
Comment on attachment 140769 [details] [diff] [review]
(Av2) <FilterEditor.js>

>+      var promptService = GetPromptService();
>+      var promptService = GetPromptService();
>+      var promptService = GetPromptService();
Oops, function saveFilter() has three declarations of promptService...

>+                     .getService()
>+                     .QueryInterface(Components.interfaces.nsIPromptService);
Please simplify this to .getService(Components.interfaces.nsIPromptService);
Attachment #140769 - Flags: review?(neil.parkwaycc.co.uk) → review-
(Assignee)

Updated

14 years ago
Attachment #140769 - Attachment is obsolete: true
(Assignee)

Comment 6

14 years ago
Created attachment 140815 [details] [diff] [review]
(Av3) <FilterEditor.js>
[Checked in: Comment 9]

Av2, with comment 5 suggestion(s).
(Assignee)

Updated

14 years ago
Attachment #140815 - Flags: review?(neil.parkwaycc.co.uk)
(Assignee)

Updated

14 years ago
OS: Windows 98 → All
Hardware: PC → All

Updated

14 years ago
Attachment #140815 - Flags: review?(neil.parkwaycc.co.uk) → review+
(Assignee)

Updated

14 years ago
Attachment #140815 - Flags: superreview?(mscott)
Blocks: 219122
(Assignee)

Comment 7

14 years ago
Comment on attachment 140815 [details] [diff] [review]
(Av3) <FilterEditor.js>
[Checked in: Comment 9]

No super-review from <mscott@mozilla.org> since "2004-02-07" :-(
Attachment #140815 - Flags: superreview?(mscott) → superreview?(Henry.Jia)

Comment 8

14 years ago
Comment on attachment 140815 [details] [diff] [review]
(Av3) <FilterEditor.js>
[Checked in: Comment 9]

sr = Henry
Attachment #140815 - Flags: superreview?(Henry.Jia) → superreview+

Comment 9

14 years ago
Fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
(Assignee)

Updated

14 years ago
Attachment #140815 - Attachment description: (Av3) <FilterEditor.js> → (Av3) <FilterEditor.js> [Checked in: Comment 9]
Attachment #140815 - Attachment is obsolete: true
(Assignee)

Updated

14 years ago
Target Milestone: --- → mozilla1.8alpha2
(Assignee)

Comment 10

14 years ago
Comment on attachment 140815 [details] [diff] [review]
(Av3) <FilterEditor.js>
[Checked in: Comment 9]

approval1.7.3=?:
This is "needed" to apply patch for bug 219122 to the branch too...
(checked in in v1.8a2: no regression so far...)
Attachment #140815 - Flags: approval1.7.3?

Comment 11

14 years ago
Comment on attachment 140815 [details] [diff] [review]
(Av3) <FilterEditor.js>
[Checked in: Comment 9]

a=mkaply
Attachment #140815 - Flags: approval1.7.3? → approval1.7.3+

Updated

14 years ago
Keywords: fixed1.7.3
(Assignee)

Comment 12

14 years ago
Comment on attachment 140815 [details] [diff] [review]
(Av3) <FilterEditor.js>
[Checked in: Comment 9]

David:
{{
I think I remember that Aviary branch is synchronized with v1.7 branch
"automatically",
or should I request approval for explicit checkin ?
}}
Well, asking for 'approval-aviary=?', as needed for bug 219122: dismiss it
and/or explain if this is not needed/appropriate.
Thanks.
Attachment #140815 - Flags: approval-aviary?

Comment 13

14 years ago
Comment on attachment 140815 [details] [diff] [review]
(Av3) <FilterEditor.js>
[Checked in: Comment 9]

a=asa for aviary checkin.
Attachment #140815 - Flags: approval-aviary? → approval-aviary+
Product: MailNews → Core
(Assignee)

Comment 14

13 years ago
(In reply to comment #13)
> (From update of attachment 140815 [details] [diff] [review] [edit])
> a=asa for aviary checkin.

This never made it to the aviary1.0 branch:
from bug 219122 comment 32
{{
not relevant to aviary.
}}

Updated

13 years ago
Attachment #140815 - Attachment is obsolete: false
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.