automatic capture mechanism for search toolbar?

RESOLVED DUPLICATE of bug 261124

Status

()

Firefox
Toolbars and Customization
--
enhancement
RESOLVED DUPLICATE of bug 261124
15 years ago
12 years ago

People

(Reporter: Jeremy M. Dolan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
An idea occured to me that I thought Firebird developers may be interested in
implementing. The search bar in Firebird is great and all (or so they tell me, I
don't use it myself), and it's easy enough to click on a plugin to have your
favorite search engine added.

If, that is, there's a plugin available. And you can locate it. And it does the
specific search you want. (Amazon DVDs, not the whole site!... etc)

It seems to me it would be relatively simple to let a user "capture" any form
field they want, for use in the search bar. Any search, no matter how small it's
userbase, would be a click or two away from Mozilla's search UI. No writing a
plugin or custom keyword for your companies intranet simply for your own
personal use.

Two UI implementations immediately come to mind.
  1) Context menu of the search field.
  2) Search bar's menu (more discoverable), which would then prompt you to
     click the field you wish to capture.

I have various other ideas for how it could be implemented, but you guys
probably have enough to go off of to determine if this is something of value.

Cheers.

Comment 1

15 years ago
Omniweb 5 actually has this feature.
(Reporter)

Comment 2

15 years ago
How dare they steal my brilliant innovation.

Hrmph.

Updated

14 years ago
OS: Linux → All
Hardware: PC → All

Updated

13 years ago
Assignee: hyatt → nobody
QA Contact: bugzilla → toolbars

*** This bug has been marked as a duplicate of 261124 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.