If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

symlinking to mozilla startup script broken

RESOLVED FIXED

Status

SeaMonkey
Build Config
--
major
RESOLVED FIXED
14 years ago
13 years ago

People

(Reporter: Andrew Schultz, Assigned: Andrew Schultz)

Tracking

({regression})

Trunk
All
Linux
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Assignee)

Description

14 years ago
after the checkin for bug 230468, symlinking to mozilla startup script is
broken.  At startup, I get:
mozilla-bin: error while loading shared libraries: libmozjs.so: cannot open
shared object file: No such file or directory

This is happening because the mozilla script now sources the run-mozilla.sh
script.  When run-mozilla.sh was executed, run-mozilla.sh could get the real
mozilla directory from `dirname $0`.  Now $0 is the path of the symlink.

I'll attach a patch that at least gets things working again.
(Assignee)

Comment 1

14 years ago
Created attachment 140667 [details] [diff] [review]
patch

this just sets MOZ_DIST_BIN with the mozilla script instead of re-sniffing it
within run-mozilla.sh
(Assignee)

Updated

14 years ago
Attachment #140667 - Flags: superreview?(leaf)
Attachment #140667 - Flags: review?(bsmedberg)

Comment 2

14 years ago
*** Bug 233035 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 3

14 years ago
symlinking has worked since ~1.1, and I think people use it a lot (3 people have
noticed it so far).  They're going to be unhappy if it doesn't work in 1.7a.
Flags: blocking1.7a?
Hardware: PC → All
(Assignee)

Comment 4

14 years ago
Created attachment 140675 [details] [diff] [review]
patch v2

run-mozilla.sh still needs to set MOZ_DIST_BIN if it's not already set (if
run-mozilla.sh gets invoked directly).
Attachment #140667 - Attachment is obsolete: true
(Assignee)

Updated

14 years ago
Attachment #140675 - Flags: superreview?(leaf)
Attachment #140675 - Flags: review?(bsmedberg)
(Assignee)

Updated

14 years ago
Attachment #140667 - Flags: superreview?(leaf)
Attachment #140667 - Flags: review?(bsmedberg)

Comment 5

14 years ago
Comment on attachment 140675 [details] [diff] [review]
patch v2

Ouch. Symlinks. Horrible. ;-(

I think the issue can be solved much easier, patch coming up in  afew secs...
Attachment #140675 - Flags: review?(bsmedberg) → review-

Comment 6

14 years ago
Created attachment 140676 [details] [diff] [review]
Cure for the mess, patch for 2003-02-04-trunk

Updated

14 years ago
Attachment #140675 - Attachment is obsolete: true

Updated

14 years ago
Attachment #140676 - Flags: superreview?(leaf)
Attachment #140676 - Flags: review?(ajschult)
(Assignee)

Comment 7

14 years ago
Comment on attachment 140676 [details] [diff] [review]
Cure for the mess, patch for 2003-02-04-trunk

how about "exec"?  that's what was there before.  Is there any advantage to not
exec'ing?

Comment 8

14 years ago
Andrew Schultz wrote:
> (From update of attachment 140676 [details] [diff] [review])
> how about "exec"?  that's what was there before.  Is there any advantage to 
> not exec'ing?

"exec" replaces the current shell process with the process being launched. After
that no further line will be executed in the shell script - which means the
shutdown scripts will not be run anymore.
(Assignee)

Comment 9

14 years ago
Comment on attachment 140676 [details] [diff] [review]
Cure for the mess, patch for 2003-02-04-trunk

ah, yes.  exec would prevent the "stop" scripts from working.  and much simpler
than what I had.
Attachment #140676 - Flags: review?(ajschult) → review+

Comment 10

14 years ago
*** Bug 233097 has been marked as a duplicate of this bug. ***

Comment 11

14 years ago
Comment on attachment 140676 [details] [diff] [review]
Cure for the mess, patch for 2003-02-04-trunk

ceding superreview of this to bsmedberg (don't have a linux machine handy to
test).
Attachment #140676 - Flags: superreview?(leaf) → superreview?(bsmedberg)

Comment 12

14 years ago
This patch solves the problem in bug 233097.

Updated

14 years ago
Attachment #140676 - Flags: superreview?(bsmedberg) → superreview+
checked in
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Flags: blocking1.7a?
Resolution: --- → FIXED

Comment 14

14 years ago
*** Bug 233257 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

14 years ago
Attachment #140675 - Flags: superreview?(leaf)
Product: Browser → Seamonkey

Comment 15

13 years ago
omission of exec killed Mozilla BeOS ability to start from script

https://bugzilla.mozilla.org/show_bug.cgi?id=235691

That's a real pain which prevents me working at BeOS port since march 2004 (!!!!)

I hope if use of "exec" is really prohibited, maybe some wise person can propose
other solution?
You need to log in before you can comment on or make changes to this bug.