when focus is on flash content, browser keyboard short cuts stop working (e.g. apple-t)

VERIFIED DUPLICATE of bug 78414

Status

()

Core
Plug-ins
VERIFIED DUPLICATE of bug 78414
14 years ago
14 years ago

People

(Reporter: Philipp Ringli, Assigned: Peter Lubczynski)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7a) Gecko/20040204

as soon as the flash content (using flash player 7r19, i did not test with lower versions, but assume it's 
all the same) got focus, keyboard shortcuts are ignore by the browser. apple-t, apple-n won't work 
anymore. you have to focus the adress input field to get keyboard-short cuts working again.

Reproducible: Always
Steps to Reproduce:
1. goto http://www.binderlaw.ch (or any other page with flash content)
2. focus the flash content, by clicking somewhere inside the flash content.
3. try apple-T or apple-N
Actual Results:  
the short cuts won't work.

Expected Results:  
the short cut's should work. apple-t shoud open a new tab, apple-N should open a new window.
This is because the keyboard signals are sent to the flash applet by Mozilla,
because the flash applet has focus.  Marking invalid as this is the desired behavior
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

14 years ago
Alexander,

why do you think that only the mozilla team is handling the flash plugin correctly in assuming that your 
way is the only and desired way?
please explain to me, why hasn't this been the behaviour in the past releases? like mozilla 1.5?
or why do other browsers like IE, Safari and Opera handle it in a way that browser short cuts still work 
when flash content has focus?

you might want to follow this thread on the flashcoders mailing list as it grows:
http://chattyfig.figleaf.com/cgi-bin/ezmlm-cgi?1:sss:103102:200402:pclapbbbckbdjkcbnndm#b

and please: reconsider.

cheers,
phil
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Well, I assume it is the correct behavior because the the flash can also either
use or ignore the keyboard shortcuts.  IE does the same (not that I'm using that
as a reference implementation.)

I may be wrong though - sorry for jumping to conclusions.

Either way, desired behavior or not, changing hardware and OS to all because I
see this on numerious versions of Moz on 'doze
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: MacOS X → All
Hardware: Macintosh → All
(Reporter)

Comment 4

14 years ago
Thanks Alexander!
It might be a good idea to ask Macromedia, what their opinion on this issue is.
They must have some sort of guide lines on how Browsers should implement the Flash Plug-In.

Comment 5

14 years ago
*** Bug 233243 has been marked as a duplicate of this bug. ***

*** This bug has been marked as a duplicate of 78414 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.