Mozilla does not let the Gnome onscreen keyboard know the accessible objects until one of the objects is in focus

RESOLVED DUPLICATE of bug 235719

Status

()

Core
Disability Access APIs
RESOLVED DUPLICATE of bug 235719
14 years ago
14 years ago

People

(Reporter: Michael Lew, Assigned: Aaron Leventhal)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7a) Gecko/20040120

When running mozilla with the Gnome Onscreen Keyboard (GOK), GOK does not
recognize that Mozilla has any accessible items until one of Mozilla's
accessible items is 'in focus'.  Normally, the Menus button in GOK should become
active if the active window has objects that are accessible.  With Mozilla, even
if the browser window is active, the items do not appear as menu items to GOK
until one of Mozilla's accessible items is given focus and then the browser lets
GOK know that there are available items that it needs to let the user know about.

Additionally, if the browser has more than one window open, once Mozilla reports
to GOK that it has accessible items it tells GOK about all of the accessible
items on every window not just the active one.  So, if you have 3 Mozilla
browser windows open and you click on the Menus button in GOK, you will get a
GOK window that has 3 File buttons, 3 Edit buttons, 3 View buttons, 3 help
buttons, etc.

Not sure if this is 2 separate problems.  To me it just looks like Mozilla is
having a hard time telling which window is active and then sending the
information for that window/dialog.  I recreated this on Linux as well as AIX.

Reproducible: Always
Steps to Reproduce:
1. Start mozilla (mozilla -profilemanager) with accessibility options turned on
2. Start GOK
3. Notice that the Menus button is not made available in the GOK window
4. Right click on any of the accessible items in the profilemanager like one of
the checkboxes
5. Notice that the GOK Menus button now made available.

Could do it this way too:
1.  Start Mozilla with accessibility turned on
2. Start GOK
3. Notice Menus option in GOK not available
4. Right click on the File pulldown menu on the Mozilla browser window
5. Notice the Menus option now available



Actual Results:  
The GOK Menus button became available.

Expected Results:  
GOK should have been made aware of Mozilla's accessible items without having to
select one of the items.  Just being the active window, Mozilla should have let
GOK know that there were items that are accessible.

Updated

14 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 1

14 years ago
I believe this is a duplicate of 235719.

*** This bug has been marked as a duplicate of 235719 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.