Crash when building with --disable-oji and you load a java plugin

RESOLVED WORKSFORME

Status

()

defect
P2
normal
RESOLVED WORKSFORME
15 years ago
10 years ago

People

(Reporter: mscott, Unassigned)

Tracking

({crash})

Trunk
x86
Linux
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.9.2 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
If you build the app with --disable-oji (which Thunderbird does), but java is
still installed in the common mozilla plugins folder, we still load the java
plugin. Then the java plugin calls back into our app and it can't get the JVM
Manager so it aborts, causing our app to also abort. 

When OJI is not defined, we should not even be trying to load the java plugin.

See Bug #223600 for more details.
(Reporter)

Comment 1

15 years ago
in nsPluginHostImpl, I see a routine called isUnwantedJavaPlugin

which should in theory keep us from finding the java plugin when we scan the
plugins directory (ScanPluginsDirectory).

http://lxr.mozilla.org/seamonkey/source/modules/plugin/base/src/nsPluginHostImpl.cpp#4870


I wonder why that code isn't keeping us from loading the java plugin on linux

Updated

15 years ago
Blocks: 223600

Updated

13 years ago
Blocks: 353557

Updated

13 years ago
No longer blocks: 353557
Assignee: peterlubczynski-bugs → nobody
QA Contact: plugins
Blocks: 445063
Flags: blocking1.9.2?

Comment 2

10 years ago
the problem is that in order to get mime types on unix/mac, you have to load the library, by the time you've loaded the library, you've been killed. if you survive killing, you can get mime types and find out you don't want it.

on windows, mime types can be read w/o loading the library (not that we necessarily do that, just that it's technically possible because they're part of a windows resource instead of just an npapi).

Comment 3

10 years ago
Josh, can you verify that this isn't a problem any more (now that OJI is removed completely)?
Flags: blocking1.9.2? → blocking1.9.2+
Priority: -- → P1
While there, there seems to be one last removal to do on m-c:
{
/build/package/debian/rules
    * line 31 -- --disable-netcast --disable-java --disable-oji --disable-static \
}
Attachment #390905 - Flags: review?(ted.mielczarek) → review+
Comment on attachment 390905 [details] [diff] [review]
Remove --disable-java and --disable-oji.

While you're there, just hg rm all of build/package/debian. Neither Debian nor Ubuntu actually use that, and it hasn't been touched in 10 years. (Note that it only supports the Mozilla suite anyway!)
This is a P1 1.9.2 blocker, thus blocking Firefox 3.6a1 - any ETA on landing?

Updated

10 years ago
Priority: P1 → P2
Josh, is this still a problem? Please see comment #2. The attached patch really doesn't have anything to do with a possible crash on the mac (and really should've been in a different bug anyways, but oh well).
Flags: blocking1.9.2+ → blocking1.9.2-

Comment 9

10 years ago
My linux machine is out of commission for a bit, I'll take a look when I have access to it again.
Assignee: nobody → joshmoz

Comment 10

10 years ago
removed "build/package/debian" on mozilla-central

http://hg.mozilla.org/mozilla-central/rev/30ee68a628df

Comment 11

10 years ago
I don't get any crash on Mac OS X when loading the JEP despite the fact that OJI is missing. I also don't get any crashes on Linux and I don't see a single Java-related crash stack in our crash stats in any version of 3.6.

Closing this out.
Assignee: joshmoz → nobody
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.