gopher page continues and updates wrong tab if original tab is closed during load

RESOLVED WORKSFORME

Status

()

Core
Networking
--
minor
RESOLVED WORKSFORME
14 years ago
12 years ago

People

(Reporter: Peter Brodersen, Assigned: Darin Fisher)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113

Any gopher-page in a tab which is loading will continue to load if you close the
tab.

Furthermore, it will update the tab that is now active. It shouldn't meddle with
other tabs, when it has been closed.

The problem only seems related to pages using gopher but is reproducable under
any gopher-page. 

Reproducible: Always
Steps to Reproduce:
1. Open another tab
2. Go to any gopher-page, e.g. gopher://gopher.quux.org/
3. Click a "link" on the gopher-page and QUICKLY close the tab before the new
gopher-page is loaded

Actual Results:  
The tab closes, but the gopher-resource is still loaded, now into another tab.

Expected Results:  
The tab should just close and the gopher-request should be aborted/ignored, just
like closing any other tab where a resource is loading.

Note that the problem only occurs on gopher-resources (as far as I have checked)
- no problem with HTTP or FTP.

It seems to be reproducable of any gopher-page (if you're able to find any :)
(Reporter)

Comment 1

14 years ago
The error only seem to happen when you enter a folder (like "Archives" or
"Computers" at the given URL: gopher://gopher.quux.org/ ) - not if you access a
file. For an easy test, just open this URL in a new tab, click on a folder, and
quickly close the tab.

At my last test it even updated a tab in another window (I had several
Mozilla-windows with several tabs open).
(Reporter)

Comment 2

14 years ago
It even seems that the resource - when interrupted (when closing the tab) -
isn't loaded fully, but will only give the name of the directory/folder the user
has entered.
Assignee: tabbed-browser → darin
Component: Tabbed Browser → Networking
QA Contact: benc

Updated

14 years ago
QA Contact: benc → gopherqa

Comment 3

14 years ago
I see this on LInux 2004030208
OS: Windows XP → All

Comment 4

14 years ago
I see this on Win98 1.7 RC1.
Also confirming that this is Gopher-specific (HTTP and FTP are fine).

Comment 5

13 years ago
Confirmed on x86 Linux Firefox 1.0.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

13 years ago
Blocks: 194220

Comment 6

12 years ago
Works on current trunk.  Fixed sometime this month, although I'm not exactly sure when; bug 312760 seems likely, but I don't see a need to check.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

12 years ago
The issue is still present in Bon Echo.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 8

12 years ago
Bon Echo is 1.8 branch-based; please don't reopen core bugs based on it.  This works in current trunk (1.9) builds.  Yes, I know it's confusing that the latest alpha doesn't have fixes from a while ago, but the Firefox devs wanted a stable base to work from for Firefox 2.0, so it uses basically the same rendering engine as FF 1.5.
Status: REOPENED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.