Closed Bug 233384 Opened 16 years ago Closed 16 years ago

Downloaded file time stamp is not last modified time but download time

Categories

(SeaMonkey :: Download & File Handling, defect)

x86
Windows 2000
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 178506

People

(Reporter: peter, Unassigned)

Details

User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6) Gecko/20040113

When I download a file, I find that its time stamp, which is supposed to
indicate its modified time and date, is instead set to the time and date of the
download - even when the actual modified time and date is available from the server.

Reproducible: Always
Steps to Reproduce:
1. Go to any directory on the Internet which has no index page and so returns a
 file list, e.g. http://www.qaya.org/academic/hebrew/
2. Choose any one file of the files listed, note the "last modified" date and
time indicated
3. Right click on the file name, choose "Save link target as...", and select a
suitable location
4. When the download has finished, look at the downloaded file e.g. with Windows
Explorer

Actual Results:  
File modified time and date is the time and date of the download

Expected Results:  
File modified time and date should be the same as listed on the page from which
the file was downloaded.

*** This bug has been marked as a duplicate of 178506 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
(In reply to comment #1)
> 
> *** This bug has been marked as a duplicate of 178506 ***

Sorry about the dupe, but when I searched for "download file time stamp" or
something similar I got 200 or so matches but this wasn't one of them. A bug in
bugzilla?
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.