If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

autoscroll misbehaves when escaped by middle clicking

RESOLVED DUPLICATE of bug 216899

Status

()

Firefox
General
--
minor
RESOLVED DUPLICATE of bug 216899
14 years ago
14 years ago

People

(Reporter: Lee Aylward, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20040130 Firebird/0.7

When I am engaged in autoscroll and attempt to stop autoscrolling by using the
middle mouse button, the browser jumps to google (or whatever is in the
quicksearch bar) and searches for whatever is in my clipboard. Sometimes it
jumps to google and is quickly forwarded to a random webpage.

Reproducible: Always
Steps to Reproduce:
1.Start autoscrolling by clicking the middle mouse button
2.Click the middle mouse button again after you have scrolled some

Actual Results:  
I was forwarded to this webpage when I middle clicked while autoscrolling.
http://www.esreality.com/?a=post&id=605443

Expected Results:  
It should quit autoscrolling and remain the current page.
more fun with contentLoadURL and autoscroll!

*** This bug has been marked as a duplicate of 216899 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.