need search criteria "whole header"

RESOLVED DUPLICATE of bug 229142

Status

--
enhancement
RESOLVED DUPLICATE of bug 229142
15 years ago
9 years ago

People

(Reporter: gullevek, Assigned: sspitzer)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20040113 Firebird/0.7

I would like to place a filter for any kind of string appearing in the mail
header. I have a possibilty to do this for the body, but not for the header. I
can't use the "customize field" because this field "Recieved:" appears several
times and if I put this into the customize field, then only the first one seems
to checked.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.




almost every mail client I know has this featuer.

Comment 1

15 years ago
I see a little bit different behaviour. Each Received header will be searched if
there are more then one. But only the first line of it while Received headers
mostly consist of several lines.

I think that would help you. Do you nevertheles want to have a whole-header "field"?
(Reporter)

Comment 2

15 years ago
I see. Then the problem is, that my information is actually in the 3rd line.
Then it might be another bug, that he doesn't search the other lines if there
are more.

Thought still it would be nice to be able to search for "string" in <header>
like eg in kmail or TheBat!

Comment 3

15 years ago
Ok, I rephrased the subject to better match this bugs issue.

BTW, the problem to handle multi-line headers incorrectly is subject of bug 124641.
OS: Linux → All
Hardware: PC → All
Summary: can't create filter for any message in header → need search criteria "whole header"
Product: MailNews → Core

Comment 4

13 years ago
This is a dup of bug #229142

Comment 5

13 years ago

*** This bug has been marked as a duplicate of 229142 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: Core → MailNews Core
This bug should be reopened (or perhaps duped to some other bug), as it is not a duplicate of bug 229142:

This bug is about implementing "Find in headers" (which might be considered a part of bug 271222 whose scope however is not very clear), whereas bug 221942 is about implementing "Find in entire message // both headers and body" (I'm using the terminology of bug 271222 comment #1). Clearly, these are two different requests.
You need to log in before you can comment on or make changes to this bug.