Last Comment Bug 233567 - css :hover state doesn't work properly with this background-moving technique
: css :hover state doesn't work properly with this background-moving technique
Status: RESOLVED WORKSFORME
: regression
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: unspecified
: PowerPC Mac OS X
: -- normal (vote)
: ---
Assigned To: Blake Ross
:
Mentors:
http://www.simplebits.com/tips/tab_ro...
: 233905 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-09 13:17 PST by Ludvig
Modified: 2004-02-15 09:39 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Ludvig 2004-02-09 13:17:16 PST
User-Agent:       
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

The tabs at this page should have a hover state (which worked in firebird 0.7).
In Firefox 0.8 the hover state dosn't seem to differ from the normal state.

One thing about this tabs is that they use a special technique
(http://www.simplebits.com/archives/2003/09/30/accessible_imagetab_rollovers.html)
 where the background position is changed in the hover state. 

Another note on this bug:
"I’ve found that if you leave the mouse over a menu item on page load, it may
load in the :hover state but then stick like that, without allowing actual
hovering. This is in both OS X and Windows 2000, by the way."
(http://www.mezzoblue.com/archives/2004/02/09/importance_o/index.php)


Reproducible: Always
Steps to Reproduce:
1. Go to the specified URI
2. Move the mouse over the tabs (home, guides, magazine, archive)
3. Notice that nothing happens

Actual Results:  
The tabs doesn't change at all.

Expected Results:  
Moved the background-image of the tab to the position of -20px.
Comment 1 Ludvig 2004-02-09 13:24:00 PST
Looks like Jeremy found a solution on the css side, but still the tabs doesn't
render the same way as in Firebird 0.7

Css solution:
http://www.jeremyflint.com/tabs.html

Posted at:
http://www.mezzoblue.com/archives/2004/02/09/importance_o/index.php#c003764
Comment 2 James Graham 2004-02-09 14:28:03 PST
This is wfm on a trunk build from a week or so ago Gecko/20040124 (linux) I
suspect the problem is 0.8 branch only.
Comment 3 José Jeria 2004-02-11 11:29:30 PST
*** Bug 233905 has been marked as a duplicate of this bug. ***
Comment 4 José Jeria 2004-02-11 11:30:31 PST
Can anyone test this with a trunk bild on MacOS X?
Comment 5 Jonathan Louie 2004-02-12 17:20:10 PST
well, that page doesn't seem to work with firefox 0.8 release win2k or mozilla
1.6 release win2k.  i'll check with firefox mac when get back to my mac.
Comment 6 José Jeria 2004-02-13 02:34:36 PST
Now there is a trunk build available for MacOS X, can anyone re-test?
ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/
Comment 7 Ludvig 2004-02-13 03:20:58 PST
Looks like it's working now...
Comment 8 José Jeria 2004-02-13 03:25:25 PST
Ludvig, you mean its working with a nightly build?
Comment 9 Ludvig 2004-02-13 03:50:16 PST
Yes, i tried the one José linked to.

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7a) Gecko/20040212
Firebird/0.8.0+
Comment 10 Charles Fenwick 2004-02-15 09:39:04 PST
Marking WFM based on comments 7 and 9.

Note You need to log in before you can comment on or make changes to this bug.