combine 'save as' , 'save as charset' and 'export to text' in the File menu of composer

RESOLVED EXPIRED

Status

SeaMonkey
Composer
RESOLVED EXPIRED
14 years ago
8 years ago

People

(Reporter: Jungshik Shin, Unassigned)

Tracking

({intl})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
This is a spin-off of bug 232742. 

CUrrently, composer's 'File' menu has both 'Save' and 'Save As Charset'. The
dialog box for the former pormpts only for the title while the latter prompts
for both the title and the character encoding to save a document in. These two
had better be combined into one because 1) 'Save As Charset' is not clear  2)
combining two into one, we can use a more widely used (thus better understood by
more users) 'Save As...' 

If we combine these into one, the character encoding selection part has to come
up _prefilled_ with the value selected in 'View' menu.
(Reporter)

Comment 1

14 years ago
ooops. it's bug 232722

Comment 2

14 years ago
(In reply to comment #0)
>Currently, composer's 'File' menu has both 'Save' and 'Save As Charset'.
And Export to Text?

>If we combine these into one, the character encoding selection part has to
>come up _prefilled_ with the value selected in 'View' menu.
It already does...
(Reporter)

Comment 3

14 years ago
I don't know why I haven't realize that there are 'Save', 'Save As' and 'Save As
Charset'. I'm wondering what's the difference between 'Save' and 'Save As'
(well, I can figure it out, but I'm just lazy here). 

So, we have to combine all four of them (including 'export to text') into one. 

Comment 4

14 years ago
No, "Save" saves with defaults.
> I don't know why I haven't realize that there are 'Save', 'Save As' and 'Save As
> Charset'. I'm wondering what's the difference between 'Save' and 'Save As'
> (well, I can figure it out, but I'm just lazy here). 
>
> So, we have to combine all four of them (including 'export to text') into one

No way. "Save" has to remain. "Save as" dialog can be extended to also allow
charset update but "Save" and "Save as" are distinct. Please do NOT aggregate
those two.
(Reporter)

Comment 6

14 years ago
You're right. I don't know what I was thinking. BTW, I haven't taken this. I'm
not that much interested in (fixing) this bug :-)
(Reporter)

Comment 7

14 years ago
sorry for bug spam. forgot to change the summary line
Summary: combine 'save' and 'save as charset' in the File menu of composer → combine 'save as' , 'save as charset' and 'export to text' in the File menu of composer

Comment 8

14 years ago
I think this bug needs to be changed or resolved as wontfix.

Save As *could* be combined with Export to text but there are some issues the
core editor would need to resolve and the standard save dialog on each platform
would have to work properly for our needs (I'm not sure if that is the case or
not; long ago it was not).

Save As charset could be combined with save as if the save as dialog had a
charset selector but none (last I checked) provided such UI.

I lean toward making this WONTFIX.
In the meantime I will set to Future.
Target Milestone: --- → Future
(Reporter)

Comment 9

14 years ago
A couple of observations:

1. The dialog box for 'Save As Charset' already has the check box 
for 'Export to Text'. As long as it works well, we can just get rid of 'Export
to Text'.

2. 'Save As' and  'Save As Charset' don't directly invoke the native 'file save'
dialog. The XP dialog box pops up asking for the title of an html document and
the character encoding. Only then, the native file save dialog box comes up. 

Comment 10

14 years ago
>1. The dialog box for 'Save As Charset' already has the check box 
>for 'Export to Text'. As long as it works well, we can just get rid of 'Export
>to Text'.

I disagree with this.  Most people who want to export as text won't think to
look under "Save As Charset" to find it.  If anything, the Export to Text dialog
should have the charset dropdown and the checkbox should be removed from that
dialog.


>2. 'Save As' and  'Save As Charset' don't directly invoke the native 'file 
>save' dialog. The XP dialog box pops up asking for the title of an html 
>document and the character encoding. Only then, the native file save dialog box 
>comes up. 

The XP dialog box which prompts for the title does not always appear.  If the
document already has a page title, you won't see that dialog.  If we really want
to annoy users who are doing save as, we could add the charset to the page title
dialog.  At this point, I'm not in favor of it.  (Personally, I happen to do
save as and add version numbers to the file names and changing the charset
and/or title isn't something that would change so it would be really annoying.)

Comment 11

14 years ago
(In reply to comment #10)
>Most people who want to export as text won't think to look under
>"Save As Charset" to find it.
On the other hand, they might well try "Save As..."?
(Reporter)

Comment 12

14 years ago
(In reply to comment #11)
> (In reply to comment #10)
> >Most people who want to export as text won't think to look under
> >"Save As Charset" to find it.

  For sure, I agree with you on this. As Neil wrote, they might well (if not,
'would') try 'Save As ...'. 

JS> we can just get rid of 'Export to Text'.

  I guess the above statement led to your misunderstanding. What I meant was
that we  can  'get rid of |export to text| and the current |Save As| and rename
|Save As Charset| to |Save As ...|'.  Note that this bug sprang from the desire
to get rid of 'Save As Charset' (because 'Save As Charset' sounds awkward).

  Anyway, you don't like that either because even if both title and character
encoding are prefilled in the XP dialog box for 'Save As ...', it's one more
step (one more mouse click on 'Ok' button) for users.   
Product: Browser → Seamonkey
Assignee: composer → nobody
QA Contact: composer
Target Milestone: Future → ---

Comment 13

9 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 14

8 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but still has no comment since the inception of the SeaMonkey project 5 years ago.

Because of this, we're resolving the bug as EXPIRED.

If you still can reproduce the bug on SeaMonkey 2 or otherwise think it's still valid, please REOPEN it and if it is a platform or toolkit issue, move it to the according component.

Query tag for this change: EXPIRED-20100420
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → EXPIRED
You need to log in before you can comment on or make changes to this bug.