Password Manager doesn't work if a website fills a username field by itself

RESOLVED DUPLICATE of bug 229762

Status

()

Toolkit
Password Manager
RESOLVED DUPLICATE of bug 229762
14 years ago
10 years ago

People

(Reporter: Oli Kurt, Assigned: Brian Ryner (not reading))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

Many websites (e.g. ebay) are using a cookie to store and retrieve the username.
In these cases the password manager doesn't show up the password, because the
field isn't empty after the page load.

I (and many people I asked) think that it would be useful if the password
manager overwrites the username and password. (Did that Mozilla already, didn't it?)

By the way, I think that it is no solution to disable cookies (or to set them
"for the current session only")

Reproducible: Always
Steps to Reproduce:
1. (enable cookies) 
2. login to ebay.com, store the password in the password manager
3. close the firefox
4. try to re-login to ebay.com
(Assignee)

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 229762 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.