Css Height property not honored for <html /> element.

VERIFIED DUPLICATE of bug 15405

Status

()

VERIFIED DUPLICATE of bug 15405
15 years ago
12 years ago

People

(Reporter: rcabral, Assigned: dbaron)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113

Using the XHTML 1.1 DTD:

If you apply a CSS definition for the default rendering of the <html> element 
that includes a height assignment, the height assignment is ignored. By 
default, the <html> element is rendered to fill 100% of the vertical space of 
the canvas (less any margin & border settings).

Reducing the size of the canvas (window) resizes the <html> element until the 
element is the minimum size to contain the <body> content.


Reproducible: Always
Steps to Reproduce:
1. Apply the following CSS:
------------------------------
html {
	background-color:Teal;
	border:solid 2px yellow;
	margin-top:10px;
	margin-bottom:10px;
	margin-left:10px;
	margin-right:10px;
	padding-top:10px;
	padding-bottom:10px;
	padding-left:10px;
	padding-right:10px;
	width:80%;
	height:500px;
}
body {
	background-color:White;
	border:solid 2px red;
	margin:50px;
	padding:10px;
	width:500px;
	height:400px;
}
------------------------------

2. Create a simple web page that references the XHTML 1.1 DTD. Include above 
CSS in an external reference. A simple web page containing a small amount of 
text container(s) in the <body> tag. (a single <p> is sufficient)

3. Vertically resize the window to note the dynamic resizing of the <html> 
element regardless of the element's defined "height" property.

Actual Results:  
Mozilla did not honor the height setting. - Width settings are honored.

Expected Results:  
The software should have drawn the yellow border @ the 500px mark, and the 
border should not have resized when the window's vertical dimensions were 
adjusted.

I also attempted to apply the height style setting inline, and was 
unsuccessful.

*** This bug has been marked as a duplicate of 15405 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.