bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Browser refuses to open plain text file if file extension is a known type (browser too smart for my good).

RESOLVED DUPLICATE of bug 57342

Status

Core Graveyard
File Handling
RESOLVED DUPLICATE of bug 57342
15 years ago
2 years ago

People

(Reporter: Chad Lowe, Unassigned)

Tracking

Trunk
Sun
Solaris

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.6) Gecko/20040116

Trying to open .c, .h or .py (and probably many others), results in Mozilla
presenting a dialog stating "The file whateva.c is of type text/x-c-source (C
source code), and Mozilla does not know how to hanlde this file type....".

Only options given are:
 - open in default app (gedit)
 - Open with ...
 - Save to disk ..

There is no option to DISPLAY the file in the browser as plain text (which
Mozilla should just do without any questions). There is no way to force Mozilla
to display this plain text file other than to change the file extension.

Mozilla should just display the files which it knows are plain text. Here is a 
usage scenario (method I have used Netscape in past):

I open the C source code file written by Japanese contractors in one tab.
I have dictionary.com's translator page open in another tab.
I copy/paste Japanese comments between pages for translation.
Rinse/wash repeat all day long for my job.

Thanks.

Reproducible: Always
Steps to Reproduce:
1. File -> Open File
2. Change "Files of type:" to All Files(*)
3. Select a source code file (any language).

Actual Results:  
- Dialog prompts for what Mozilla should do.
- Display the file is not an option.


Expected Results:  
Should have displayed the file because it knew that it was plain text. Or,
should at least have a "display as plain-text" option.

*** This bug has been marked as a duplicate of 57342 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Updated

15 years ago
OS: SunOS → Solaris
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.