The default bug view has changed. See this FAQ.

Allow Accept header to be set based on build configuration

RESOLVED DUPLICATE of bug 125682

Status

SeaMonkey
Build Config
--
enhancement
RESOLVED DUPLICATE of bug 125682
13 years ago
13 years ago

People

(Reporter: James Graham, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       
Build Identifier: 

Browsers should only contain accept header entries for formats they actually
support. Allowing the accept header to vary based on the build config will, in
principle, allow websites to distinguish between e.g. default camino builds
which have --disable-mathml and self built builds with mathml included. This bug
effectively blocks adding these more specific MIME types to the accept header.
Including these will be helpful in improving content-type negotiation.


I'm not at all sure this shouldn't be in a different component (e.g.
Networking:HTTP)

Reproducible: Always
Steps to Reproduce:

*** This bug has been marked as a duplicate of 125682 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.