SpellCheck focused text form elements

RESOLVED FIXED

Status

()

P3
enhancement
RESOLVED FIXED
19 years ago
13 years ago

People

(Reporter: william, Unassigned)

Tracking

(Depends on: 1 bug, {helpwanted})

Trunk
helpwanted
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
We are designing a client/server system to replace a legacy terminal based
system.  I would give my eye teeth (whatever they are) to be able to invoke the
mail reader's spell checker from a textarea in the browser, via javascript.

Updated

19 years ago
Assignee: nobody → beppe

Comment 1

19 years ago
Beth, didn't you suggest a feature like this?

Updated

19 years ago
Assignee: beppe → kin
Component: Misc → Editor
OS: Windows 98 → All
Product: Architecture → Browser
QA Contact: nobody → sujay
Hardware: PC → All
Summary: Not a Bug: a strong REQUEST, nay a BEG..... → SpellCheck text form elements
Target Milestone: M14
Version: 5.0 → other

Comment 2

19 years ago
reset platform/os to all; set milestone to M14; change summary; change product

and component; set qa contact; reassign to kin (is it still the same bug? ;-) )

Updated

19 years ago
Status: NEW → ASSIGNED

Comment 3

19 years ago
Accepting bug.

Comment 4

19 years ago
there is a bug in m20 - 16409, that this is probably a dup of -- Kin, you may
want to review that one.

Comment 5

19 years ago
m15
Target Milestone: M14 → M15

Comment 6

19 years ago
Moving all non-beta1 bugs to M16 since I am going on sabbatical.
Target Milestone: M15 → M16

Comment 7

19 years ago
enhancement, moving to m20
Severity: normal → enhancement
Target Milestone: M16 → M20

Comment 8

19 years ago
moving to future milestone
Assignee: kin → beppe
Status: ASSIGNED → NEW

Updated

19 years ago
Assignee: beppe → kin
Target Milestone: M20 → Future

Comment 9

19 years ago
reassigning bback to Kin

Comment 10

19 years ago
Accepting bug.
Status: NEW → ASSIGNED

Comment 11

19 years ago
adding help wanted keyword
Keywords: helpwanted

Comment 12

19 years ago
This definitely looks like a dup of Bug #16409.

Updated

18 years ago
Blocks: 16409

Comment 13

18 years ago
this is to be able to check one form element at a time (at least that's my 
reading); bug #16409 is for checking all form elements on one page
Summary: SpellCheck text form elements → SpellCheck focused text form elements

Comment 14

18 years ago
*** Bug 107596 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Depends on: 56301

Updated

17 years ago
No longer depends on: 56301

Updated

17 years ago
Blocks: 119232

Updated

17 years ago
Depends on: 129704
*** Bug 206169 has been marked as a duplicate of this bug. ***
This would be useful even if the spellchecker only underlined mispelled words
(as many word processors do).  If that's substantially easier, it would make a
great first step.

The ability to check spelling would eliminate a lot of emberrasing mispellins
that we all see too often.

(Keywords: TEXTAREA text input from spell spelling spellchecking spellchecker
rfe feature underline mispelled words)

Comment 17

16 years ago
*** Bug 219558 has been marked as a duplicate of this bug. ***

Comment 18

16 years ago
Any idea how much time / cost it would take to do this? 

It would really be a great new feature now that spellcheck is in the trunk. 
*** Bug 224157 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Assignee: kinmoz → nobody
Status: ASSIGNED → NEW
Component: Editor: Core → Spelling checker
QA Contact: sujay → core.spelling-checker

Updated

15 years ago
Target Milestone: Future → ---

Comment 20

13 years ago
This was implemented in bug 302050.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Comment 21

13 years ago
Bug 302050 is Firefox specific.  Are you sure that the fix made it's way to SeaMonkey?  If not, then this bug shouldn't be resolved, as it targets core (both browsers).

Comment 22

13 years ago
As peer my comment in bug 16409, this capability not exists in core, and the saemonkey people can enable it if they want without too much work. Seamonkey doesn't have to use it for the core bug to be fixed.

Comment 23

13 years ago
Filed SeaMonkey specific bug 338319 as follow-up.

Comment 24

13 years ago
Are we missing something, 
I see spellcheck on TEXTAREA and INPUT field, 
But NOT for design mode text in midasdemo 
( http://www.mozilla.org/editor/midasdemo/ )

Now more and more sites are now using design mode 
You need to log in before you can comment on or make changes to this bug.