Layout mis-rendered when using back button, OK on re-load

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
15 years ago
12 years ago

People

(Reporter: benoitl1, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

When navigating the above site, the page loads fine, but when going to a linked
page, and then pressing the "back" button, the original page is mis-rendered
(looks like an additional column is added to the layout).
Pressing the reload renders the page correctly.


Reproducible: Always
Steps to Reproduce:
1. Go to http://www.retrouvailles.ca/ecole.php?Ecole=9881
2. Select a name (for example Monique Tremblay)
3. Hit back button

Actual Results:  
Desk & Chair image & search box are rendered in the middle of the screen instead
of the left side.

Expected Results:  
Layout should have been the same as when page initially loads.

Comment 1

15 years ago
Hi Benoit,

Works for me on Mac, 20040212 Firebird/0.8.0+

When I hit the back arrow, the chair and text box appear in the middle of the
screen for a split second, but then it draws the middle and right columns, and
everything is back as it was.


Maybe it's a Windows-specific bug. Are you able to attach a screenshot of what
the page looks like to you?

thanks :)
(Reporter)

Comment 2

15 years ago
Created attachment 141407 [details]
Screen Capture of Layout

This is the layout after hiting the back button.
It does not correct itself like it does on your setup.

Comment 3

15 years ago
Weird! If nobody else checks it out first, I'll try it in Windows XP from work
tomorrow.

Comment 4

15 years ago
The page redraws correctly for me on Windows XP, 20040210 Firebird/0.8.0+

So maybe there's a local problem.

It looks like you're using the standard theme, but do you have any third party
extensions installed? If so, could you please try disabling them and see if the
page loads then?

If not, could you please try starting the browser with a fresh profile:
Either trash your old profile (temporarily at least), or start the profile
manager (see:
http://texturizer.net/firebird/faq.html#profilemanager). Your user profile is
likely to be found in C:\Documents and Settings\<your user name>\Application
Data\Phoenix\

Please let us know if either of these things work.
(Reporter)

Comment 5

15 years ago
Disabled RSS extensions -> No effect.  Still have layout problem
Created a new profile   -> No effect.  Same layout problem.

I also discovered that the layout problem also occurs with the forward button.
E.g.  press back, re-load, press forward -> mis-displayed

Comment 6

15 years ago
I'm afraid I'm at a loss to explain it! We're using the similar browser versions
and the same OS. But I can't reproduce it. I'm hoping someone else can.

Only other thing I can to consider... after you disabled your extensions, did
you empty the cache before trying to reload the page?
(Reporter)

Comment 7

15 years ago
Looks like an issue with loading from cache...
I went back to the page, and did a few back/forward to have a few mis-layed 
out pages.
I then cleared the cache
With the cache cleared, the first time I hit back or forward, the page is 
layed out correctly.
But once the page is in cache, it gets rendered incorrectly.

I have disabled my one extension, and it made no difference.

Comment 8

15 years ago
Benoit, can you try the latest nightly build? There were some changes made on
the trunk (which is what nightlies are made of) that weren't made on the branch
(which is what the 0.8 release is made of) that could remedy this.

Comment 9

15 years ago
Did this bug ever go away for you, Benoit? If so, could you please reply using
the comments box in the bug page? If we don't hear back from you, I'll set it as
WORKSFORME in a few days.

cheers

Comment 10

15 years ago
One final thought... (if you are still reading this), there's Flash on the page.

Are you using the latest versions of the Flash and Shockwave Players (from
macromedia.com)? If not, that may have affected the rendering.

Comment 11

15 years ago
worksforme with 20040425 Firefox on winXP
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Updated

12 years ago
QA Contact: bugzilla → toolbars
You need to log in before you can comment on or make changes to this bug.