Wrong onMouseOver= gets called.

VERIFIED DUPLICATE of bug 12232

Status

()

P3
normal
VERIFIED DUPLICATE of bug 12232
19 years ago
18 years ago

People

(Reporter: jonas_b, Assigned: vidur)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
I will attach a document with two almost identical <div> blocks.
Both have a "position: absolute" style but only one block is visible at a time
You can use an <input> button to toggle which block to show.

Both blocks contains links with onMouseOver= functions.
It doesn't matter which block is visible the onMouseOver of the last block
always gets activated, it doesn't matter if the block is hidden or not.

Netscape 4 and IE 5 doesn't behave this way.

I have tested this on both win32 and linux, it is the same except the linux
version likes to crash when displaying alert(""); windows.

/ Jonas Borgström
(Reporter)

Comment 1

19 years ago
Created attachment 4073 [details]
A testcase of this bug, works in mozilla, ns4, ie5.

Comment 2

19 years ago
Nice test case! (See also bug #22168).
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 3

19 years ago
DUP of 12232.

*** This bug has been marked as a duplicate of 12232 ***

Comment 4

19 years ago
verified dup 12232 [EVENTTARG] events going to wrong element: visibility=hidden
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.