crash when javascript tries to replace/overwrite one popup with another

RESOLVED DUPLICATE of bug 203041

Status

SeaMonkey
General
--
critical
RESOLVED DUPLICATE of bug 203041
15 years ago
14 years ago

People

(Reporter: Kelledin, Unassigned)

Tracking

({qawanted})

Trunk
x86
Linux
qawanted

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040130

At any one of the topic threads at http://episteme.arstechnica.com/ (for  
example  
http://episteme.arstechnica.com/eve/ubb.x?a=tpc&s=50009562&f=48409524&m=495000542121),  
there is a "Reply with Quotes" for each post that pulls up a JavaScript popup.   
Unfortunately, if two of these "Reply with Quotes" popups are opened at once in  
Mozilla, the browser closes silently for no professed reason. 
  
(For informational purposes, earlier Mozilla versions such as 1.4 crash with a 
"segmentation fault" error.  End result is the same.) 

Reproducible: Always
Steps to Reproduce:
1. Go to  
http://episteme.arstechnica.com/eve/ubb.x?a=tpc&s=50009562&f=48409524&m=495000542121 
2. Register or log in, then return to the above page once you're logged in. 
3. Click on the double-quote graphic ("") at the upper-right corner of any 
post.  This will pull up a javascript popup. 
4. In the original mozilla window, click on the double-quote graphic again. 
 
Actual Results:  
Mozilla closed all its windows unexpectedly. 

Expected Results:  
Well, this is debatable.  The current ArsForum code driving 
episteme.arstechnica.com is currently in a rather beta-ish state.  Judging by 
how Konqueror behaves in this case, the ArsForum code wants to either replace 
the first popup window with a second one of identical size, or fill the first 
popup with new contents (I can't tell which, but the practical end-result 
should be the same).  While IMHO this isn't really an ideal behavior for the 
ArsForum code (it should create a second popup without destroying the first), 
Mozilla itself should handle it rather more gracefully than simply crashing. 

Judging from the page source, the crash is occurring in the JavaScript function 
sizePopup().  I'm sadly unable to debug this further without the ArsForum code 
handy, though...
Very unlikely to be JS engine.... if you can attach the page to this bug (save
as "web page, complete"), that would help -- needing a login to test makes it a
little difficult to do so...
Assignee: general → general
Component: JavaScript Engine → Browser-General
Keywords: qawanted
QA Contact: pschwartau → general

Comment 2

15 years ago
Created attachment 141425 [details]
page in question

per bz's request

Comment 4

15 years ago

*** This bug has been marked as a duplicate of 203041 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.