Setting 'Inline Style' for HTML message body persistently overrides Composition preferences

RESOLVED DUPLICATE of bug 249882

Status

MailNews Core
Composition
RESOLVED DUPLICATE of bug 249882
14 years ago
10 years ago

People

(Reporter: Mike Cowperthwaite, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
xref bug 147645; this is largley copied from that bug:

It seems that a global style for {HTML Message Compose <body>} is created on 
startup, initialized by the Composition preferences; and that this style gets 
changed by the Advanced Edit|Inline Style dialog.

"Current body style" apparently defaults to only the fg/bg colors, font, and 
font-size as specified by   Preferences|Mail&News|Composition.

However, any changes made in the compose window via
  Format|Page Colors and Background|Advanced Edit|Inline Style
are applied not only in the message, but to subsequent messages.

In other words, if you set up the Inline Style the way you want it in the 
Advanced Edit page and click OK, that's how all the HTML messages will be 
formatted/styled from then on.  (The style is global to all accounts.)

However, this "setting" does not persist over Mozilla sessions, so it cannot be 
used as the sort of style template desired by reporter.  There are also certain 
other actions that can be taken that will reset the style, but I haven't figured 
out exactly what they are.


To reproduce:
1) Set up HTML composition prefs with a particular color scheme
2) Open a new HTML Compose Message window
3) Format | Page Colors and Background | Advanced Edit | Inline Style tab
4) Set CSS styles for 'color' and 'background-color', and any other styles
   that suit you -- border, margin, background-image, etc.
5) Complete message and send
6) Open a new HTML Compose Message window

Actual results:
Message window has the same formatting as the previous message

Expected results:
Message window is formatted according to Composition preferences, with no CSS 
carryovers from previous message.
(Reporter)

Comment 1

14 years ago
Note that setting a CSS background image on the Inline Style tag will also 
persistently apply to subsequent messages, and the selected image file name will 
be preselected in the {Page Colors and Background} dialog (and the image itself 
will be seen in the sample box).

Also, see bug 234252.
(Reporter)

Comment 2

14 years ago
Workaround, from bug 192557 comment 14:
> A manual style set on the body persists after the compose window is recycled,
> the cure is to open a second [composition] window.
mike, see bug #249882.  
Depends on: 249882
(Reporter)

Comment 4

14 years ago
This bug has been fixed, presumably by the fix for 249882.  Duping.

*** This bug has been marked as a duplicate of 249882 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.