keyboard shortcuts don't work when viewing PDF, Flash etc

VERIFIED DUPLICATE of bug 78414

Status

()

Firefox
General
VERIFIED DUPLICATE of bug 78414
15 years ago
14 years ago

People

(Reporter: Robert Karlsson, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

When a page contains a plugin object (such as Flash, pdf etc) and focus is on
the plugin part of the page (the plugin area has for one reason or another been
clicked) or the viewed page is a plugin document (like when the url to a pdf
document is entered in the address bar) Firefox doesn't catch any keyboard
shortcuts entered (such as ctrl-t, ctrl-n, ctrl-tab, alt-f etc). When viewing
pdf documents (and other plugin file types) new tabs, new windows, shifting tabs
etc has to be handled via the mouse and menu bar.
Examples can easily be found, but for convenience:
http://www.albinoblacksheep.com/flash/badgers.php (for a flash part of page example)
http://www.math.su.se/matstat/und/proci/pdf/tentor/030314.pdf (for a full page
pdf example)

Reproducible: Always
Steps to Reproduce:
1. Have suitable plugins installed (Adobe Reader, Flash Player ...)
2. Go to site with plugin content (examples above)
3. Click on plugin area to focus on it if embedded in html document
4. Try to use keyboard shortcuts

Actual Results:  
Nothing.

Expected Results:  
New tab opened, other tab activated, new window opened, file menu opened etc

Comment 1

15 years ago
Please reopen if you disagree.

*** This bug has been marked as a duplicate of 78414 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.