Closed Bug 234709 Opened 21 years ago Closed 21 years ago

"comment N" in attachment title garbles linkification of "attachment A"

Categories

(Bugzilla :: Creating/Changing Bugs, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 232861

People

(Reporter: dbaron, Assigned: myk)

Details

When an attachment (number A) title has "comment N" in it and a bug comment
contains "attachment A", the linkification of "attachment A" produces a title
attribute in which "comment N" is recursively linkified, which produces garbage
HTML.

When producing a TITLE attribute for a link, strings such as "comment N" should
not be recursively linkified.

Steps to reproduce:
  Display bug 234686 comment 2 or bug 234686 comment 3

Actual results (for bug 234686 comment 3):
  The patch in <a href="attachment.cgi?id=141634&amp;action=view" class=""
title="patch implementing proposal in <a href="#c1">comment 1</a>">attachment
141634 [details] [diff] [review]</a> ...

Expected results (for bug 234686 comment 3):
    The patch in <a href="attachment.cgi?id=141634&amp;action=view" class=""
title="patch implementing proposal in comment 1">attachment 141634 [details] [diff] [review]</a> ...
I think bugzilla garbled the actual and expected results above a bit as well.
*** This bug has been marked as a duplicate of 232861 ***

*** This bug has been marked as a duplicate of 232861 ***
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.