Closed Bug 234876 Opened 16 years ago Closed 16 years ago

Remove %FORM from token.cgi

Categories

(Bugzilla :: User Accounts, defect)

2.17.6
defect
Not set

Tracking

()

RESOLVED FIXED
Bugzilla 2.18

People

(Reporter: wicked, Assigned: wicked)

References

Details

Attachments

(1 file, 1 obsolete file)

Change token.cgi to not use %FORM as per bug 225818.
Blocks: 225818
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Target Milestone: --- → Bugzilla 2.18
Attached patch Changes, V1 (obsolete) — Splinter Review
Attachment #141737 - Flags: review?
Attachment #141737 - Flags: review? → review?(jouni)
Comment on attachment 141737 [details] [diff] [review]
Changes, V1

Wouldn't it be nicer to avoid all the Bugzilla statements and use a

my $cgi = Bugzilla->cgi; 

in the beginning of the file?
Attached patch Changes, V2Splinter Review
I agree, here is a revised patch. I also changed |Bugzilla->cgi->header();|
lines to use the new variable. BTW, those lines were the reason why I used that
syntax in this file in the first place..
Attachment #141737 - Attachment is obsolete: true
Attachment #142440 - Flags: review?(kiko)
Attachment #141737 - Flags: review?(jouni)
Comment on attachment 142440 [details] [diff] [review]
Changes, V2

(I guess Bugzilla->cgi was used because it was only calls originally)

Looks correct, and follows Bugzilla style (as doeditparams.cgi exemplifies, for
instance). Make sure the tests run here before comitting.
Attachment #142440 - Flags: review?(kiko) → review+
Flags: approval?
It was only *two* calls originally, I say.
Flags: approval? → approval+
Depends on: 236019
No longer depends on: 236019
Checking in token.cgi;
/cvsroot/mozilla/webtools/bugzilla/token.cgi,v  <--  token.cgi
new revision: 1.21; previous revision: 1.20
done
Status: ASSIGNED → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.