Closed Bug 234898 Opened 16 years ago Closed 16 years ago

Start using $cgi->param in queryhelp.cgi

Categories

(Bugzilla :: Bugzilla-General, defect)

2.17.6
defect
Not set

Tracking

()

RESOLVED FIXED
Bugzilla 2.18

People

(Reporter: wicked, Assigned: wicked)

References

Details

Attachments

(1 file)

Eliminate obsolete %FORM vars from queryhelp.cgi by changing them to $cgi->param.
Blocks: 225818
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attached patch Version 1Splinter Review
Unless I'm missing something, there was no reason to get the value of product
parm  so I removed it.
Attachment #141751 - Flags: review?
Attachment #141751 - Flags: review? → review?(kiko)
Comment on attachment 141751 [details] [diff] [review]
Version 1

I can't seem to disagree with you. I've been fishing through bonsai and the
lines have been here since version 1.1 of the file, though they were never
used, and gerv	added a bunch of stuff that ended up clobbering it in 1.2:
http://webtools.mozilla.org/bonsai/cvsblame.cgi?file=mozilla/webtools/bugzilla/
queryhelp.cgi&rev=1.2&root=/cvsroot
(no, cvs diff doesn't work in Bonsai there for some reason). I guess it's
something that was supposed to go in but never did. Yay for no reviews.
Attachment #141751 - Flags: review?(kiko) → review+
Flags: approval?
Target Milestone: --- → Bugzilla 2.18
uhhh....   okay. :)

Yeah, nuke that unused cruft. ;)
Flags: approval? → approval+
Checking in queryhelp.cgi;
/cvsroot/mozilla/webtools/bugzilla/queryhelp.cgi,v  <--  queryhelp.cgi
new revision: 1.22; previous revision: 1.21
done
Status: ASSIGNED → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.