Closed Bug 235031 Opened 21 years ago Closed 20 years ago

Firefox displays "blue" appearance when system is using Graphite

Categories

(Firefox :: General, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox1.5

People

(Reporter: aeyngel, Assigned: kevin)

References

Details

Attachments

(1 file)

User-Agent:       
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

When Mac OS X's System Preferences > Appearance (or General in 10.2) is set to
Graphite, Firefox continues to use blue highlighting in contextual menus.

Reproducible: Always
Steps to Reproduce:
1. Click Apple > System Preferences > Appearance (or General in 10.2)
2. Change Appearance to Graphite
3. Launch Firefox
4. Control-click (or click-and-hold) on a page or link
5. Check the color of the select-highlight.

Actual Results:  
While the rest of the system uses Graphite, and indeed, Firefox's menubars use
Graphite correctly, Firefox's contextual menus seem to be hard-coded to blue (at
least in the default theme).

Expected Results:  
Used graphite.
Kevin, this one is your baby.
QA Contact: mconnor
Hmm. Yeah. The Pinstripe menu colors and background are hardcoded because the
CSS does not provide the blue or graphite theme highlight color. So what you're
asking for may seem simple, but is not possible right now, AFAIK. This is
something to consider for the "Aquification" release of Firefox. 
Confirming, as this seems to be a valid request.
Assignee: firefox → webmail
Status: UNCONFIRMED → NEW
Ever confirmed: true
fixed on trunk
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
I'm backing out this fix, it works on your tree because you have applied the
native-form-widgets-patch on it (menupopup / menuitem patches are on bug 118025,
it's not ready yet)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Ugh. Thanks for backing it out Mano. I got the impression that 118025 had been
fixed already. My fault for not checking.
fixed.
Status: REOPENED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
Depends on: 118025
Target Milestone: --- → Firefox1.1
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: