Closed Bug 235104 Opened 18 years ago Closed 13 years ago

investigate making some string ctors non-inline

Categories

(Core :: XPCOM, defect)

defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 265534

People

(Reporter: darin.moz, Unassigned)

References

Details

(Keywords: helpwanted, perf)

investigate making some string ctors non-inline.  the introduction of
nsTFixedString added 40-55k of codesize as a result of an additional member
variable initializer per nsTAutoString ctor.  perhaps these ctors should be
non-inline.

this might also be true of many of the other non-trivial ctors, especially the
ones that already make a function call.
Severity: normal → minor
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.7beta
Target Milestone: mozilla1.7beta → mozilla1.8alpha
Keywords: helpwanted, perf
Target Milestone: mozilla1.8alpha1 → Future
Assignee: darin → nobody
Status: ASSIGNED → NEW
QA Contact: string
Target Milestone: Future → ---
Depends on: 265534
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 265534
Component: String → XPCOM
You need to log in before you can comment on or make changes to this bug.