When starting Mozilla it tells me default profile already in use so I cannot get bookmarks etc.

RESOLVED DUPLICATE of bug 151188

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 151188
14 years ago
14 years ago

People

(Reporter: Collin Starkweather, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040221

I recently switched from Red Hat to Gentoo, saving the partition with my $HOME
directory.  Mozilla is at V1.6 with Gentoo ... I can't recall what version was
running on Red Hat.

In any case, it started up just fine the first time.  The second time, it gives
me a dialog when I start it up asking me to choose a profile.  There is only one
profile available:  default.  When I try to select default, it tells me that the
default profile is already in use, so I can't use it.

I can create another profile, but as it stands I don't have access to all the
bookmarks, Password Manager information, etc. which I have invested time and
energy in and which make my browser a useful tool.

Please don't take this as a rant but as a suggestion:  It is inconceivable to me
that all of my personal information is sitting in my home directory but I am
totally unable to access it.  There should be an option a user has access to
with the startup dialog I mentioned to force Mozilla to toggle the flag that
indicates an account is in use.  Otherwise a user account can effectively be
disabled for no particular discernable reason.


Reproducible: Always
Steps to Reproduce:
1.  Start Mozilla
2.  Try to select default profile from startup dialog
3.  Gnash teeth, beat breasts

Actual Results:  
I was unable to access the default profile

Expected Results:  
I should have been able to use Mozilla normally with all of my bookmarks etc. in
place.

about:buildconfig

Build platform
target
i686-pc-linux-gnu

Build tools
Compiler 	Version 	Compiler flags
gcc 	gcc version 3.3.2 20031218 (Gentoo Linux 3.3.2-r5, propolice-3.3-7) 	-Wall
-W -Wno-unused -Wpointer-arith -Wcast-align -Wno-long-long -march=pentium4 -pipe
-s -fforce-addr -pthread -pipe
g++ 	gcc version 3.3.2 20031218 (Gentoo Linux 3.3.2-r5, propolice-3.3-7) 
-fno-rtti -fno-exceptions -Wall -Wconversion -Wpointer-arith -Wcast-align
-Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-long-long
-march=pentium4 -pipe -s -fforce-addr -Wno-deprecated -fshort-wchar -pthread
-pipe -I/usr/X11R6/include

Configure arguments
--prefix=/usr/lib/mozilla --disable-pedantic --disable-short-wchar
--disable-xprint --enable-mathml --without-system-nspr --enable-nspr-autoconf
--with-system-zlib --enable-xsl --enable-crypto --enable-extensions=default
--enable-optimize=-O2 --with-default-mozilla-five-home=/usr/lib/mozilla
--enable-toolkit-gtk2 --enable-default-toolkit=gtk2 --disable-toolkit-qt
--disable-toolkit-xlib --disable-toolkit-gtk --disable-ldap --enable-strip-libs
--disable-debug --disable-tests --enable-reorder --enable-strip
--enable-elf-dynstr-gc --enable-xft --disable-freetype2
--enable-old-abi-compat-wrappers

Comment 1

14 years ago
> saving the partition with my $HOME directory

Is there a symlink named 'lock' in the profile dir (e.g. ~/.mozilla/|profile
name|/XXXXXXXX.slt/lock) ?   Remove it.  (This would happen if $HOME was copied
while mozilla was running.)

Comment 2

14 years ago
I've seen the process hang around after i thought i quit Mozilla.
So do a "killall mozilla-bin", just in case.
(Reporter)

Comment 3

14 years ago
Removing the lock file did the trick.  Thanks, Jon!

I suppose this should be changed to a feature request for a feature in which the
dialog that tells you the profile is already in use allows the user to remove
the existing lock on the profile.

Comment 4

14 years ago
Deleting `lock' file is UNSAFE.
It's much much better to follow suggestion in the comment 2, i.e. `killall
mozilla-bin'.

Comment 5

14 years ago

*** This bug has been marked as a duplicate of 151188 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.