Option to let "View|Text Zoom" affect images as well as text

VERIFIED DUPLICATE of bug 4821

Status

Core Graveyard
Image: Painting
--
enhancement
VERIFIED DUPLICATE of bug 4821
14 years ago
8 years ago

People

(Reporter: Jan Gundtofte-Bruun, Assigned: Jim Dunn)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113

Since Mozilla has such excellent view zooming capabilities, I sometimes get in
situations where things look odd because inline or theme imagery doesn't scale
(such as smileys and images used as special characters, or just pretty borders).

It would be wonderful if there was an option to let Mozilla attempt to (more or
less crudely) scale any images to the appropriate size in proportion to the rest
of the content. I know this may look ugly, but it can be really handy -- for
instance, the Zoom feature as it is now isn't of much help to vision impaired users.

Reproducible: Always
Steps to Reproduce:
1. Load a page with inline graphics (such as the phonemes at dictionary.com).
2. Set "View|Text Zoom" to 30%, 200% or something else radical.
3. See how the images are now out of scale in respect to the rest of the content.

Actual Results:  
The inline images kept their inital size while the text around it scaled.

Expected Results:  
If the option I suggest is implemented, the images should contract/expand to the
appropriate scale in relation to the zoom factor, and thus approximately match
the text content.
(Reporter)

Comment 1

14 years ago
"...isn't of much help to vision impaired users." -- forgot to add "in relation
to images", my point being that images can only be zoomed if they're too big to
fit on one screen, but users who regularly browse at odd sizes have no means of
custom/incremental image zooming. Sorry.

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 4821 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

13 years ago
Right you are - didn't find the other bug because it doesn't have 'image' in its
description.
verified

(that bug's summary was now changed to include images)
Status: RESOLVED → VERIFIED

Updated

8 years ago
Component: Image: Painting → Image: Painting
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.