Closed Bug 235508 Opened 20 years ago Closed 19 years ago

transit.511.org needs to escape / in character classes in regular expressions

Categories

(Tech Evangelism Graveyard :: English US, defect)

x86
Windows XP
defect
Not set
minor

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 309840

People

(Reporter: timeless, Unassigned)

References

()

Details

Error: unterminated character class \
Source File: http://transit.511.org/utils/utils.js
Line: 36, Column: 13
Source Code:
	var regex =
/(http|ftp|https):\/\/[\w]+(.[\w]+)([\w\-\.,@?^=%&:/~\+#]*[\w\-\@?^=%&/~\+#])?/;

The corrected line would be:
/(http|ftp|https):\/\/[\w]+(.[\w]+)([\w\-\.,@?^=%&:\/~\+#]*[\w\-\@?^=%&\/~\+#])?/
Fixed in Firefox, see bug 309840.

*** This bug has been marked as a duplicate of 309840 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.