Software error for search in "content" field with comparison operator other than "matches"

VERIFIED DUPLICATE of bug 238544

Status

()

--
trivial
VERIFIED DUPLICATE of bug 238544
15 years ago
13 years ago

People

(Reporter: afranke, Unassigned)

Tracking

Details

(Reporter)

Description

15 years ago
When I tried the boolean charts search "content contains all of the strings"
with value "auto compl" on bugzilla.mozilla.org, I got the following software
error (which was displayed only as "</p>" in my Mozilla browser, but that's a
different issue). 
I think this comparison type is not supported for the so-called "content" field,
so it should just refuse this search in this case.

<h1>Software error:</h1>
<pre>DBD::mysql::st execute failed: Unknown column 'bugs.content' in 'where
clause' [for statement ``SELECT bugs.bug_id, bugs.bug_severity, bugs.priority,
bugs.bug_status, bugs.resolution, bugs.bug_severity, bugs.priority,
bugs.rep_platform, map_assigned_to.login_name, bugs.bug_status, bugs.resolution,
bugs.short_desc FROM bugs, profiles AS map_assigned_to LEFT JOIN bug_group_map 
ON bug_group_map.bug_id = bugs.bug_id  WHERE bugs.assigned_to =
map_assigned_to.userid AND (bugs.product_id IN (1)) AND (bugs.bug_status IN
('NEW','ASSIGNED','REOPENED')) AND (INSTR(LOWER(bugs.content), 'auto') AND
INSTR(LOWER(bugs.content), 'compl')) AND ((bug_group_map.group_id IS NULL))
GROUP BY bugs.bug_id ORDER BY bugs.bug_id '']) at Bugzilla/DB.pm line 66
	Bugzilla::DB::SendSQL('SELECT bugs.bug_id, bugs.bug_severity, bugs.priority,
bugs.bug_s...') called at /opt/webtools/bugzilla/buglist.cgi line 701
</pre>
(Reporter)

Comment 1

15 years ago
In fact, this seems to happen with pretty much all comparison operators except
"matches".  Changing summary to reflect this.
Summary: Software error for "content contains all of the strings"-type search → Software error for search in "content" field with comparison operator other than "matches"

Comment 2

14 years ago
(In reply to comment #1)
> In fact, this seems to happen with pretty much all comparison operators except
> "matches".  Changing summary to reflect this.
> 

Got the same software error when playing with the landfill.bugzilla.org. It is a
testing site but it should work, no?
Reassigning bugs that I'm not actively working on to the default component owner
in order to try to make some sanity out of my personal buglist.  This doesn't
mean the bug isn't being dealt with, just that I'm not the one doing it.  If you
are dealing with this bug, please assign it to yourself.
Assignee: justdave → query-and-buglist
QA Contact: mattyt-bugzilla → default-qa

Comment 4

13 years ago

*** This bug has been marked as a duplicate of 238544 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 5

13 years ago
Verified dupe: same error message, and the title of this bug is exactly the
problem that is solved in the other one.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.