Search sheet field doesn't always display the focus ring correctly

RESOLVED FIXED in Camino1.0

Status

--
minor
RESOLVED FIXED
15 years ago
13 years ago

People

(Reporter: chrispetersen, Assigned: sfraser_bugs)

Tracking

({fixed1.8})

unspecified
Camino1.0
PowerPC
Mac OS X
fixed1.8

Details

Attachments

(3 attachments)

(Reporter)

Description

15 years ago
Build: 2004022608
Platform: OS X 10.3.2
Expected Results: The focus ring should be displayed around the search field
What I got: Focus ring isn't painted around the edges of the search field

Steps to reproduce:

1) Remove google search field from toolbar bar
2) Select Go -> Search the Web
3) Type a word in the search field and click search
4) Again, Select Go -> Search the Web
5) The sheet doesn't have a properly painted focus ring
(Reporter)

Comment 1

15 years ago
Created attachment 142441 [details]
Screen shot of focus ring issue
this will prolly go away when we start using a real search field.
Status: NEW → ASSIGNED
Target Milestone: --- → Camino1.0

Comment 3

14 years ago
This looks to be WFM in latest private build (20041024). There's a gremlin in
that there's a noticeable (~0.25s) delay between the focus ring drawining round
the majority of the input field, and drawing round the left hand border (round
our magnifying glass icon). But its all drawn.

Chris, can you let me know how you get on with a recent build.
*** Bug 298933 has been marked as a duplicate of this bug. ***
fwiw, we cannot use the rounded text field because we use a custom cell, and
those aren't supported in with the rounded field on 10.2. So we're stuck waiting
for the "real" NSSearchTextField on 10.3+. I guess we could put in some code to
conditionaly use the view depending on the OS verison but that seems icky.
Based on Mike's comments in comment 5, I don't think this should be fixed for
1.0. It'll be too hard and not worth it. It's best just to wait until we drop
10.2 support.
Target Milestone: Camino1.0 → Camino1.2
(Assignee)

Comment 7

13 years ago
Taking.
Assignee: mikepinkerton → sfraser_bugs
Status: ASSIGNED → NEW
(Assignee)

Comment 8

13 years ago
Created attachment 203136 [details] [diff] [review]
Patch

We need to have the SearchTextField register for becomeKey and resignKey notificaitons on its window, and invalidate the focus rect if its the first responder.

The cell code that called -setKeyboardFocusRingNeedsDisplayInRect: from within the drawWithFrame: method was bogus; you can't do a -setNeedsDisplay: while drawing.
(Assignee)

Updated

13 years ago
Attachment #203136 - Flags: review?(mikepinkerton)
(Assignee)

Comment 9

13 years ago
Fixed.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Keywords: fixed1.8
Resolution: --- → FIXED
(Assignee)

Updated

13 years ago
Attachment #203136 - Flags: review?(mikepinkerton)
Target Milestone: Camino1.2 → Camino1.0

Comment 10

13 years ago
Created attachment 203295 [details]
screen shot of search bar

>comment#0
>1) Remove google search field from toolbar bar

When remove is not done from the toolbar, it still reproduces. 

Mac OS X 10.3.9
2005111621 (v1.0+)
(Assignee)

Comment 11

13 years ago
This WFM in Version 2005111604 (1.0b1+). I don't see the problem in the screenshot.

Comment 12

13 years ago
oops...
The step leaked. 

Steps to reproduce:

1) Type a word in the search field and hit retun
2) Select Go -> Search the Web


NB 2005111608 (v1.0+)
(Assignee)

Comment 13

13 years ago
I still don't see it with those steps. Maybe it's broken on the trunk still?

Comment 14

13 years ago
(In reply to comment #13)
> I still don't see it with those steps. Maybe it's broken on the trunk still?
> 

Yes, trunk build.
(It was confirmed to reproduce with a new profile to make sure.)
I am not trying 1.8branch build. 

And There was no necessity retrieved in the search bar field. 
After something is input to the Search field of search toolbar, and focus is moved, it reproduces with "Select Go -> Search the Web". 

STR:
1) Type a word in the search field
2) Click localetion bar
3) Select Go -> Search the Web
You need to log in before you can comment on or make changes to this bug.