ctrl-scroll-wheel magnification direction is opposite of normal convention

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
14 years ago
10 years ago

People

(Reporter: Rahul, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

In all the other programs that I use (including: Opera, OpenOffice.Org,
StarOffice, IBM ViaVoice Speakpad editor), control-scroll-wheel increases the
size of text when scolled up and reduces size when scrolled down. 
MozillaFirefox is the only program that responds to the same commands in the
opposite direction, which is inconsistent and confusing.  This has been tested
on Microsoft XP, but I observed the same behavior from MozillaFirebird in the
past when using RedHat 9.0.

Reproducible: Always
Steps to Reproduce:
1. hold down control key and move the scroll wheel on your mouse
2.
3.

Actual Results:  
scroll wheel up reduces text size

Expected Results:  
scroll wheel up should increase text size

Comment 1

14 years ago
this is consistent with IE so this is probably invalid
This is by design to match IE's convention.  If we're going to take market
share, we need to match on as many usability features as possible, which means
don't screw with how the mouse button behaves in IE.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
QA Contact: mconnor
Resolution: --- → WONTFIX
(Reporter)

Comment 3

10 years ago
Fours years later, Firefox is now mainstream, has nontrivial market share, and should be willing to take the lead in UI design. The need for bug-compatiblity with Microsoft should not be taken any further than necessary.

Also, Microsoft has fixed this particular problem in IE 7. So for IE 7 users, at least, Firefox's scrolling convention is now incorrect and will hinder them when they want to switch from IE 7 to Firefox.

Therefore I respectfully request that the developers take a new look at this issue.
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
Assignee: bugzilla → nobody
QA Contact: mconnor → general
Closing this as WFM

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9) Gecko/2008051206 Firefox/3.0
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.