"Save Page As..." crashes browser when the page was a local file

RESOLVED DUPLICATE of bug 235832

Status

--
critical
RESOLVED DUPLICATE of bug 235832
15 years ago
2 years ago

People

(Reporter: waynegwoods, Assigned: bugzilla)

Tracking

({regression})

Trunk
PowerPC
Mac OS X
regression

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7b) Gecko/20040226 Firefox/0.8.0+

If I open a local html file in my browser window and then select "Save Page
As...", the browser crashes immediately.

Reproducible: Always
Steps to Reproduce:
1.Navigate to a page, or even a blank starting page will do.
2.Select "Save Page As..." to save the page to your hard disk
3.Open the local file in your browser window
4.Select "Save Page As..." again

Actual Results:  
Browser crashes immediately

Expected Results:  
Saved the page

Tested with fresh profile. No extensions or themes.

Comment 1

15 years ago
Note that using "save" or "save as" on images now crashes the browser as
well...It has changed in the last week or two that this is the case.

OS X 10.3.2

Firefox:  
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7b) Gecko/20040225
Firefox/0.8.0+

This behavior is new in last few weeks' nightlies, definitely wasn't the case in
past...

Updated

15 years ago
Keywords: regression
(Reporter)

Comment 2

15 years ago
Interesting. I hadn't realized the save images thing.

I went back over previous nightlies and found that the last non-buggy build was
20040218 (right before the major Mac build meltdown... bug 234916). The first
bad build was 20040225, right after bug 234916 was fixed.

I also checked a recent Seamonkey build and found the same problem, so I'll
change the product to Browser.

That makes the images thing a dupe of bug 235832. I'll leave this bug as
separate for now, in case the save page problem is different.
Component: General → File Handling
Product: Firefox → Browser
Version: unspecified → Trunk
Yep, it's the same bug.  The patch that fixed bug 235832 also fixes this.

*** This bug has been marked as a duplicate of 235832 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.