value of hidden field not reset after reload

VERIFIED DUPLICATE of bug 46845

Status

()

Core
Document Navigation
--
critical
VERIFIED DUPLICATE of bug 46845
14 years ago
9 years ago

People

(Reporter: Mario Ivankovits, Unassigned)

Tracking

Other Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.6) Gecko/20040206 Firefox/0.8

If you modify the value of a hidden field and press reload, the page is newly
rendered, but the value of the hidden field is not reset.

Reproducible: Always
Steps to Reproduce:
Test-case attached
Actual Results:  
value of hidden field wrong

Expected Results:  
value of hidden field reset
(Reporter)

Comment 1

14 years ago
Created attachment 142522 [details]
html file to show the non-reset of the hidden field value
(Reporter)

Comment 2

14 years ago
modification of hidden field is done by javascript.

Comment 3

14 years ago
Dupe of bug 46845?
Assignee: firefox → nobody
Component: General → History: Session
Product: Firefox → Browser
QA Contact: core.history.session
Version: unspecified → Other Branch
(Reporter)

Comment 4

14 years ago
Might be, but notice, this is a hidden field, so the user has no chance to see,
that the value is wrong !!!!

I think, this is a VERY critical situation (bug).
Yep, this is a dup.

*** This bug has been marked as a duplicate of 46845 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED

Updated

10 years ago
Duplicate of this bug: 376294

Updated

9 years ago
Component: History: Session → Document Navigation
QA Contact: history.session → docshell
You need to log in before you can comment on or make changes to this bug.