HTML Clipboard Format lacks SOURCE URL

VERIFIED DUPLICATE of bug 244685

Status

defect
VERIFIED DUPLICATE of bug 244685
16 years ago
14 years ago

People

(Reporter: thunderbird, Assigned: jag+mozilla)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       
Build Identifier: Mozilla/5.0 Firefox 0.8

Technically not a bug, but it's a big shortcoming.
The HTML Clipboard Format specification allows for the inclusion of the SOURCE 
URL metadata in the header.  IE 4.0 and higher support this, but Mozilla does 
not. It would be GREAT if Mozilla could supply this information, which allows 
the pasting application to know the URL of the page that the HTML fragment 
originated from.  It will allow images to be retrieved from the original page 
or browser cache, and it also allows clipboard extenders to know where the 
data came from so that the user can re-visit the page.  
Here is an example of what needs to be here (note the Source URL):

Version:1.0
StartHTML:000000220
EndHTML:000000934
StartFragment:000000800
EndFragment:000000849
StartSelection:000000800
EndSelection:000000844
SourceURL:http://bugzilla.mozilla.org/enter_bug.cgi?product=Browser

When data is copied from Mozilla products, the HTML clipboard format is 
present, but lacks the SourceURL. It's also listed as version 0.9 (the 1.0 
comes from IE).  




Reproducible: Always
Steps to Reproduce:
1.Copy anything from any Mozilla browser
2.Examine the data on the clipboard, in HTML Format (in binary)
3.No Source URL present.  Programs like ClipMate cannot obtain the source URL.

Actual Results:  
No source URL can be determined.   Users stick with IE instead, if they're 
using a clipboard extender that extracts the source URL.  This is bad for 
everyone!

Expected Results:  
I expected the SourceURL to be provided.  The CF_HTML data isn't nearly as 
useful with this header information missing.
Please fix this bug! The failure to access the HTML source of clipped materials
hinders my ability to use Firefox as an information resource. Hopefully it will
be easy to simply pull the URL into the clipboard specification. It will appeal
to folks like me who sometimes, when getting info from the web, use EI solely
for that ability.

John French
I use a clipboard enhancer on Windows. This enhancer grabs not only what I'm 
trying to copy, but also determines the source URL and stores that with the 
clip. Thus, I have a 'bibliography' for my data.

During certain browsing sessions, where I'm doing research, I am forced to use 
IE in order to have a 'bibliography' showing where I obtained text, pictures 
and other data. I would much prefer it if I could continue to use Firefox for 
all my browsing needs.
It is really frustrating to not have SourceURL available on Mozilla based
browsers. I'm a researcher/writer & need to capture sources for future
reference. I don't want to use IE...but this is one area where (now) its
technology works better for me. Please fix this!!! 
Lynn Wasnak
#244685 has a patch to fix this.

-dave

*** This bug has been marked as a duplicate of 244685 ***
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
If this is fixed my support and love for Firefox and ClipMate will increase
greatly with improved usability. Thank you for everything.
You need to log in before you can comment on or make changes to this bug.