bad html misdirects browser

VERIFIED DUPLICATE of bug 231720

Status

()

--
minor
VERIFIED DUPLICATE of bug 231720
15 years ago
14 years ago

People

(Reporter: beast, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040206 Firefox/0.8

I coded my links page incorrectly, marking it <a
href="http//http//www.bbrkarting.com target="blank"> and the double http// sends
the browser off to microsoft.com homepage instead of giving some error message.
Microsoft.com is not my default homepage, nor even a bookmark.

Reproducible: Always
Steps to Reproduce:
1.click on poorly coded link
2.
3.

Actual Results:  
goes to microsoft.com

Expected Results:  
error message

Comment 1

15 years ago
That's because since it doesn't recognize it as a URL, it treats it as a Google
search keyword and returns the first Google result.

And if you search for http// on Google, the first result is microsoft.com.

*** This bug has been marked as a duplicate of 235478 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

*** This bug has been marked as a duplicate of 231720 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago14 years ago
Resolution: --- → DUPLICATE
Verifying old and obvious dupes. Sorry for bugspam.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.