Excessive spacing in print preview before HTML inline tag...

RESOLVED DUPLICATE of bug 109970

Status

()

Core
Printing: Output
--
minor
RESOLVED DUPLICATE of bug 109970
14 years ago
13 years ago

People

(Reporter: Laurens Holst, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

752 bytes, text/html
Details
(Reporter)

Description

14 years ago
User-Agent:       
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7a) Gecko/20040219

If you have a line with a <sub> (or similar, for example <sup>) tag in it, then
the print preview will add excessive spacing before it depending on the
preceding number of characters (or so it seems). As it covers both sub and sup
it does seem like a somewhat bigger problem, perhaps related to font sizing in
general.

I didn't test if this is actually printed, or only shows in the print preview.


~Grauw

Reproducible: Always
Steps to Reproduce:
1. Make an HTML document
2. Include a line like: <p>Print preview renders this wrong: foo<sub>bar</sub></p>
3. Go to print preview.

Actual Results:  
It adds excessive spacing between 'foo' and 'bar'.

Expected Results:  
Show the same as in the web browser.
(Reporter)

Comment 1

14 years ago
Created attachment 142800 [details]
Testcase.

Testcase - view and compare with print preview.
(Reporter)

Comment 2

14 years ago
It only shows in print preview, printing goes as it should.

~Grauw
(Reporter)

Comment 3

14 years ago
Seems to be related to selected printer somehow. Problem with print preview
disappears when Adobe Distiller or PDFWriter is selected instead of Lexmark
Z25-Z35 Color Jetprinter. In all cases it actually prints ok.

Severity -> minor
Changed description because of new test case.


~Grauw
Severity: normal → minor
Summary: Excessive spacing in print preview before <sub>, etc... → Excessive spacing in print preview before HTML inline tag...
(Reporter)

Comment 4

14 years ago
Created attachment 144234 [details]
new testcase

New testcase which also observes behaviour with <span> and <i> tags.

~Grauw
Attachment #142800 - Attachment is obsolete: true

Comment 5

14 years ago
A dependence on the printer/printer driver! That is strange. I've been looking
at the print preview bugs trying to find one dealing with faulty handling of
html tags, and this is the only one i've found so far. Check out the front
bug-reporting page, headed "Enter Bug" and do a print preview of it. I've
commented on this in bug #109970, just looked at it and noted that the reporter
attached examples including two made with different printers.

If the print preview display depends on the printer, then it's processed a
little for the printer instead of just adjusted to fit a paper-size section of
screen. Is that what the print preview code should be doing? If so, then the
print preview maybe is where all the processing should take place to make a
bitmap to send to the printer, and the printer should print the bitmap
perfectly. That's not happening, as my problem with printing text (fonts) with
Mozilla 1.7RC1 and RC2 is showing.

Comment 6

13 years ago

*** This bug has been marked as a duplicate of 109970 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.