Closed Bug 236322 Opened 16 years ago Closed 16 years ago

"Find Specific bug" form don't search words in summaries field

Categories

(Bugzilla :: Query/Bug List, defect, trivial)

2.17.6
All
Other
defect
Not set
trivial

Tracking

()

RESOLVED FIXED
Bugzilla 2.18

People

(Reporter: ilya, Assigned: myk)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/124 (KHTML, like Gecko) Safari/125
Build Identifier: 

Bugzilla 2.17.6
buglist.cgi called from "Find Specific bug" form don't search words in summaries fields, just in 
Description fields unlike wroted in "Find Specific bug" description

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Version: unspecified → 2.17.6
Specific search is Myk's baby
Assignee: justdave → myk
This is actually true.	Because of limitations in MySQL's use of indexes, we
don't actually search summaries, but when a bug's description or comments
match, we use matches in the summary to help determine relevance.

Ok, so the description of the search is inaccurate.  Here's a patch that
corrects it.
Severity: major → trivial
Status: UNCONFIRMED → NEW
Ever confirmed: true
Attachment #143636 - Flags: review?(justdave)
Comment on attachment 143636 [details] [diff] [review]
patch v1: removes mention of summary search

works for me.
Attachment #143636 - Flags: review?(justdave) → review+
Checking in template/en/default/search/search-specific.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/search/search-specific.html.tmpl,v
 <--  search-specific.html.tmpl
new revision: 1.4; previous revision: 1.3
done
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
Sorry, it not good answer for me. Here some my other patch for this problem. Its work fine for me with 
MySQL 3.23.52 and search in both places:
in Bugzilla/Bugzilla/Search.pm about line 426 where
             my $term1 = "MATCH($table.thetext) AGAINST(".&::SqlQuote($v).")";
             my $term2 = "MATCH(bugs.short_desc) AGAINST(".&::SqlQuote($v).")";
             # The term to use in the WHERE clause.
             $term = $term1;

change $term = $term1;     to    $term = "((" . $term1 . ") OR (" . $term2 . "))";

More easy type of search is more important for me coz most our users think what advanced searsh is 
TOO advanced for them
Sorry, but the additional search you are doing on the short_desc field is not
using the fulltext search, it's doing a regular search on that field.  MySQL can
only use one index per table, which in the case of the bugs table is the one it
uses for the JOIN, so it does a regular (and slow, especially on large DBs)
search on the summary field in the bugs table for the query you are trying.  See
EXPLAIN for the details.
Target Milestone: --- → Bugzilla 2.18
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.