Java plug-in complains if general.useragent.vendor preference is set to "MSIE".

VERIFIED DUPLICATE of bug 83376

Status

()

defect
--
minor
VERIFIED DUPLICATE of bug 83376
16 years ago
15 years ago

People

(Reporter: rniess, Assigned: peterlubczynski-bugs)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113

My bank had me add a user-defined preference is about:config named
general.useragent.vendor and give it a string value "MSIE" as a tempoarary work
around for a browser checking bug on their web page.  Unfortunately, once this
is set, starting Mozilla fresh yields a popup dialog behind the Mozilla spash
image titled "Jave Plug-in Error" with the text "Java Plug-in for Netscape
Nvigator should not be used in Microsoft Internet Explorer.  Please use Java
Plug-in for Microsoft Internet Explorer instead."  Only button available is OK.
 After clicking OK, everything seems to operate normally until the next time
Mozilla is started fresh (ie after closing all Mozilla windows and waiting a few
seconds).  Probably an issue with Sun's Java plug-in, not Mozilla, but not sure
how to report this to Sun directly so...

Reproducible: Always
Steps to Reproduce:
1.Open a mozilla window
2.Enter URL "about:config"
3.Right-click in the body and choose New -> String
4.Enter general.usergent.vendor as the preference name.
5.Enter MSIE as value
6.Exit Mozilla completely (all windows)
7.Start Mozilla


Actual Results:  
A popup dialog appears titled "Jave Plug-in Error" with the text "Java Plug-in
for Netscape Navigator should not be used in Microsoft Internet Explorer. 
Please use Java Plug-in for Microsoft Internet Explorer instead." 
Dialog appears behind splash screen until you click on it's titlebar to bring it
to the foreground.  Mozilla does not continue loading until you click OK.

Expected Results:  
Program should start as normal with no pop-up dialog.

Tried upgrading to latest Sun 1.4.2.03 Java J2SE from unknown prior revision, no
change.

Comment 1

16 years ago
This is not only a dup, it's in the release notes.
http://www.mozilla.org/releases/mozilla1.6/known-issues.html#java

*** This bug has been marked as a duplicate of 83376 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.