Open with or Save to disk cannot be configured for PDF with Reader installed

RESOLVED DUPLICATE of bug 236195

Status

()

Core
Plug-ins
--
major
RESOLVED DUPLICATE of bug 236195
15 years ago
15 years ago

People

(Reporter: Greg Colyer, Assigned: Peter Lubczynski)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6) Gecko/20040113

If Adobe (formerly Adobe Acrobat) Reader is installed, Mozilla seems to ignore
the Helper Applications settings for application/pdf, warning that it handles
the type internally. (If Reader is uninstalled, this doesn't apply, so it is
hardly "internally", but that is not the point of this bug-report.)

The problem is that with Adobe Reader 6.0 (at least), even if all the browser
integration is switched off under Internet settings, it is still launched as a
plug-in by Mozilla. So it is not possible to get Mozilla either to launch Reader
as a helper application or Save to disk instead.

I consider this major because the former choice can be necessary for certain
sites in connection with the failure of HTTP/1.1 byte-ranging (which is not used
if the entire PDF is downloaded and then passed to a helper as opposed to an
HTTP-aware plug-in); the latter choice avoids the overhead of launching another
application, and saving can also be the only way to get some PDFs with
corruption or display problems.

The user should be able to control Mozilla's behaviour for a MIME type
independently of third-party software.

Reproducible: Always
Steps to Reproduce:
1. Install Adobe Reader.
2. Disable Reader web integration and/or configure Mozilla helper settings.
3. Visit a PDF document.

Actual Results:  
Reader is launched and PDF opens in browser.

Expected Results:  
Open with or Save to disk settings should be respected.

Work-around: use right-click to save the PDF; then launch Reader manually.
(Reporter)

Comment 1

15 years ago
Same thing happens with the same version of Mozilla but Acrobat Reader 5.1.

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 236195 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.