If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

-moz-opacity broken in Moz1,6/FF.8 in MacOS X

RESOLVED DUPLICATE of bug 228441

Status

SeaMonkey
General
--
major
RESOLVED DUPLICATE of bug 228441
14 years ago
13 years ago

People

(Reporter: todd, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6) Gecko/20040113
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.6) Gecko/20040113

specifying the proprietary -moz-opacity css attribute on any element in Mozilla
1.6 or FireFox .8 for MacOS X renders the element invisible rather than
transparent!!! Severly breaks any page using -moz-opacity. This problem is not
occuring before 1.6-based browsers or on Windows platform. Please check.

Reproducible: Always
Steps to Reproduce:
1.specify any amout of -moz-opacity on a  <div/> element. the element will
disappear completely.
2.
3.

Actual Results:  
element disappears

Expected Results:  
element should become transparent
Reporter:
-moz-opacity changed AFAIK and matches now the CSS spec.
Please attach a working screenshot, 192.168.0.x is a private IP and can not be
accessed from outside.
(Reporter)

Comment 2

14 years ago
Sorry, original expample link provided was a private IP. Here is an example URL:

http://ditchnet.org/JSGallery/dragSelect.html


NOTE: I've downloaded the latest nightly build of Mozilla and FireFox for Mac OS
X. In those two, the bug is fixed.

I also downloaded Moz 1.7alpha for Mac OS X. Here, the bug still exists.

Looks like someone has fixed the bug, we just need to make sure the fix makes
it's way into Moz 1.7 final.

BTW, link for latest nightly builds of FireFox on the site is broken.
>NOTE: I've downloaded the latest nightly build of Mozilla and FireFox for Mac OS

That means that it's fixed.
dbaron changed -moz-opacity recently back but the "-moz" prefix means that it
can always change !

-> wfm (works in the latest builds)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Comment 4

14 years ago
this is already fixed.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 5

14 years ago

*** This bug has been marked as a duplicate of 228441 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.