Closed Bug 2366 Opened 24 years ago Closed 24 years ago

http://www.the-park.com: Assertion in CSS code

Categories

(Core Graveyard :: Viewer App, defect, P1)

x86
Windows 98

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: christinehoff4, Assigned: troy)

References

()

Details

[PP] Using 1/13 build on Win 98, Win NT and Win 95.
Open URL in Viewer.
Crashes with the following details (will not crash EVERY time but has crashed
on all three platforms):

VIEWER caused an invalid page fault in
module RAPTORHTMLPARS.DLL at 015f:0067128b.
Registers:
EAX=00000573 CS=015f EIP=0067128b EFLGS=00010246
EBX=0000000c SS=0167 ESP=0091fab4 EBP=0091fb4c
ECX=00000573 DS=0167 ESI=00acb650 FS=4a27
EDX=0000000c ES=0167 EDI=00000022 GS=0000
Bytes at CS:EIP:
8b 51 04 33 c0 85 d2 7e 11 8d 42 ff 89 41 04 8b
Stack dump:
00674e14 00000022 00acb650 00abd410 006738fe 00000022 00000022 00000000 00abd410
00abd410 00000000 00000000 00000042 00ab8eb0 00000000 00000000
Summary: [PP] Crash upon loading URL → [PP]http://www.the-park.com: Crash upon loading URL
Assignee: rickg → amusil
Alex -- can you please look into this. I can't reproduce it, but there are
plugins and I'm wondering if its related.
Jan 15 optimized Mac crashes as well, PPC Illegal instruction _HWPriv+03C30
Summary: [PP]http://www.the-park.com: Crash upon loading URL → http://www.the-park.com: Crash upon loading URL
if it has crashed on all 3 reference platforms then its no a PP bug.
Its an XP bug that we need to fix
Status: NEW → ASSIGNED
If it's crashing on Mac and X, it's probably not a plugin bug, but could still be
happing due to a bug in object tag handling.  I'll take a look.
Setting all current Open/Normal to M4.
per leger, assigning QA contacts to all open bugs without QA contacts according
to list at http://bugzilla.mozilla.org/describecomponents.cgi?product=Browser
Assignee: amusil → troy
Status: ASSIGNED → NEW
Summary: http://www.the-park.com: Crash upon loading URL → http://www.the-park.com: Assertion in CSS code
This doesn't crash but I get an assertion in
nsCSSFrameConstructor::CantRenderReplacedElement():
NS_ASSERTION(PR_FALSE, "unexpected tag")

Reassigning to Troy since CVS blame shows that he has touched that code last.
CantRenderReplacedElement() does not know about EMBED tag, and I am not sure if
it should, thus assertion. I think this is a place where the "default plugin"
(in old school terms) could be invoked.
Severity: normal → major
QA Contact: 3853 → 3849
Target Milestone: M4 → M3
beppe, can you get us a regression here, all platforms, latest build, apprunner.
 Thanks!
QA Contact: 3849 → 4110
assigning bug to ChrisD -- Chris can you try this again in apprunne and see if
you get the same crash, thanks.
Using 3/16 build on Win 95, Win 98, Win NT, Mac85. and Linux. Page does NOT
crash.
Status: NEW → RESOLVED
Closed: 24 years ago
Resolution: --- → FIXED
I'm going to go ahead and mark this as fixed, if we run into problems we cna
reopen or submit new bug
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.