Closed Bug 236607 Opened 16 years ago Closed 16 years ago

Crash when choosing File | Import

Categories

(Firefox :: Migration, defect, critical)

x86
Windows 98
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 236673

People

(Reporter: skydaemon80, Assigned: bugs)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7b) Gecko/20040304 Firefox/0.8.0+
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7b) Gecko/20040304 Firefox/0.8.0+

When attempting profile migration by choosing File | Import from the main
Mozilla Firefox browser window (*not* the Bookmarks Manager window), Firefox
crashes.

Note: This was tested on aebrahim's unofficial nightly build.

Reproducible: Always
Steps to Reproduce:
1. Open a Firefox browser window.
2. Choose the "Import..." command from the "File" menu.


Actual Results:  
Firefox crashes.


Expected Results:  
Firefox begins the profile migration process.


Windows error message:
  "FIREFOX caused an invalid page fault in
   module FIREFOX.EXE at 017f:00875f57."
When Firefox crashes, the message I get is

"The instruction at [some hex value] referenced memory at 0x0000000"

this happens with aebrahim's unofficial nightly build (03/04/2004), my own build
(03/05/2004) and a couple of builds by other people.


Athlon XP CPU / Windows XP Pro
Has Ben checked in a fix for this? Using Mozilla/5.0 (Windows; U; Windows NT
5.1; en-US; rv:1.7b) Gecko/20040307 Firefox/0.8.0+ I no longer get a crash on
File | Import.
(In reply to comment #2)
> Has Ben checked in a fix for this? Using Mozilla/5.0 (Windows; U; Windows NT
> 5.1; en-US; rv:1.7b) Gecko/20040307 Firefox/0.8.0+ I no longer get a crash on
> File | Import.

Not sure, but I'm still crashing here on Windows 98 SE.  Tested on both mozjf's
and your build.
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7b) Gecko/20040307 Firefox/0.8.0+
As of Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040308
Firefox/0.8.0+ It is still crashing.
I do not get a crash, but import does not work.  

First I get a warning: reference to undefined property
Components.interfaces.nsIBrowserProfileMigrator
Source File: chrome://browser/content/migration/migration.js
Line: 1.

Then I get an error: Error: kIMig has no properties
Source File: chrome://browser/content/migration/migration.js
Line: 6
(In reply to comment #5)
> I do not get a crash, but import does not work.  
> 
> First I get a warning: reference to undefined property
> Components.interfaces.nsIBrowserProfileMigrator
> Source File: chrome://browser/content/migration/migration.js
> Line: 1.
> 
> Then I get an error: Error: kIMig has no properties
> Source File: chrome://browser/content/migration/migration.js
> Line: 6

You might want to file another bug report for that... if that hasn't been
reported already.
This WFM on the latest nightly on WinXP (2004-03-12). Can anyone reproduce this
on a platform other than Windows 98 with the latest nightly? I'm just checking
to see if this is solely a win 98 bug.
Still crashing for me... Using my own homemade build under WinXP-Sp1 (you can
donwload it here : http://pryan.org/mozilla/firefox/mozjf/

NB : based on CVS sources up to date on this saturday, midnight mozilla.org,
using this .mozconfig :

. $topsrcdir/browser/config/mozconfig

ac_add_options --disable-tests
ac_add_options --disable-debug
ac_add_options --disable-pedantic
ac_add_options --disable-shared
ac_add_options --enable-static

ac_add_options --enable-optimize='-O1 -G6'

export BUILD_OFFICIAL=1
export MOZILLA_OFFICIAL=1
mk_add_options BUILD_OFFICIAL=1
mk_add_options MOZILLA_OFFICIAL=1 

So, any answer ?
OK, I just tried your build Frederic and it still works perfectly for me (apart
from it doesn't recognise my installation of Opera 7.5 beta2). It detected that
the only other browser I had installed was IE (although I never use it) and it
imported the settings fine. I then installed mozilla 1.6 and tried again. Again
it provided me with the correct options (apart from Opera) of IE or Mozilla and
both seemed to import perfectly, although I notice only bookmarks are imported
from mozilla. I didn't install any extensions or themes for this test. I tried
with a brand new profile and with a profile auto imported on startup from my
previous installation. WinXP SP1. So Frederic, do you have any other browsers
installed that are causing this to crash (ie. NS 4.x I presume) or perhaps its
an extension problem. Other than that, I'm stumped.
A few additional notes: I uninstalled opera and reinstalled the latest beta of
7.5, this time allowing it to store my profile in %appdata% instead of in the
program folder. Firefox now recognises it in the import dialog and it (again)
works flawlessly. Try as I might, I can't get File->Import to crash...
>So Frederic, do you have any other browsers

I only have this *bip* IE 6.0Sp1 and a current CVS based trunk build of mozilla 

>installed that are causing this to crash (ie. NS 4.x I presume) or perhaps its

Don't have this one anymore.

>an extension problem. Other than that, I'm stumped.

No extension besides "tinderbox icon".

So, now ?
This is really odd. I can't think what is causing the crash on your system. I'm
using the same build, same (ie. no) extensions, have the same other browsers
installed and am using the same operating system. I presume you are testing with
a clean install and profile (although I have tested with both a new and old
profile and still can't get it crash). If not, that might be worth a try. Can
anybody else seeing the crash give details of what system they are using and any
other relavent details? Does anybody see this on Linux or Mac?
>I presume you are testing with
>a clean install and profile (although I have tested with both a new and old
>profile and still can't get it crash).

When migration code was officially added, I used it to make a blank new profile
(but not for my bookmarks which where from my old profile ;o).

>If not, that might be worth a try.

I tried it. :[

I will try in a vmware box with a winxp in it to see if it is still happening.

Note that recently (2 days ago) I had a crash and so, I made a brand new install
of my WinXP + SP1 + all critical patches...

I'm a little lost here... :[
More info for comment #12 :

1) I installed a brand new windows XP/Sp1 in a vmware box. Only brower available
is IE 6.0 Sp1
2) I copied my last optimized firefox build.
3) I "un7zipped" it in a folder.
4) First launch of firefox : crash
5) Second launch, ok.
6) File / Import -> crash :[

Do I have to try with Win98Se or Millenium ?
I get the same result on a homebrew build under Windows XP. I'm building on MSVC
.NET 2003 using "-01 -G6" as the optimization options. I'll try doing a debug
build to see if I can't get a stack trace.
Attached file stack trace
This is the stack trace I get from MSVC's debugger. I also see an assertion
about allocating memory of size 0.
I found that the zip build will crash even with a clean install, but the
installer build (.exe) will not.
The installer build does not crash, but when I choose file-import, I cannot get
past the first screen. Pressing Next does absolutely nothing, no matter what
browser I pick to import from.
Anton, I used to have that bug as well, before things got to the state where it
would crash before it even got that far. In retrospect, I think you're right.
When I was using installer builds I had that problem, and when I made my own
build in MSVC .NET 2003 I get the crash. I don't know if the two bugs have any
relation, however.
I've submitted bug 237918. 
 
Summary:  Installer build throws javascript error on file->import and import
dialog does not function
Yes.  I get this bug too.  The 3/20/04 seems to have this partially fixed.  The
dialog will appear now but it does not do anything.  Only the cancel button works.
I have this bug too. I had only just changed from the installer to the zip
version. As soon as I asked to import it crashed with the invalid page fault.
I'm using Win98SE with IE 5.5 I could still do a longer kind of bookmark export
from IE and then have FireFox import those into it's own bookmarks, but the
settings is where it needs the import wizard.
Could be related to (or a duplicate of) bug 236673.

I installed Opera 7.23, and no more crash file / import.

NB : I am using WinXP. Anybody can confirm with Win98/Me ?
I believe this to be related to OS version. This does not work on build 20040321
on Windows 2000 (no effect on pressing next in wizard), while it does work on
Windows XP. (Not to mention that zipped build crash on Windows 2000 and does not
crash on Windows XP -- though I was unable to find bug about this).
Confirm W2K Clicking next does nothing.

Gecko/20040325 "Official Build" Installer
This was fixed for me by the checkin for bug 236673. I think this is probably
safe to mark as a dupe, unless someone is still crashing in tomorrow's nightlies.
Confirming that selecting File|Import no longer crashes Firefox under WinXP.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040401
Firefox/0.8.0+ (chaosite)

*** This bug has been marked as a duplicate of 236673 ***
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.