As it stands the appearance of a separator in the bookmark manager is just like
that of a bookmark. I think we should go for a more functional appearance.
I like the way Firefox makes them look but know that would be rather hard to do
Created attachment 143583 [details]
An image to show how it might look.
I think that removing the bookmark icon from the separator appearance and
giving it a new title "---------" would make it look and feel more like a
Why use text dashes? Surely we can draw a real separator there.
Sure we could, it's just that that would take a whole lot more coding.
(In reply to comment #3)
> Sure we could, it's just that that would take a whole lot more coding.
This should be fixed as a cosmetic fix when the bookmarks are overhauled. I'd
hope that as Mac users we'd expect someting a bit more better looking than -----
so I agree with Greg's comments about using a "real" seperator.
The idea was to have a better looking separator untill somebody actually took
the time to create a real one. What we do now is way more bad then having ---.
I agree the sperator should look good.
Just what is supposed to "look good"?
I thought that the idea was to make something that was visually obvious that there was a separation
between different groups of bookmarks. A line of some sort does this very simply and is sufficiently
obvious that it passes the "Little Abner Rule" (as any fool can plainly see).
The present "<Menu Spacer>" is essentially useless as it does not stand out from the bookmarks at all.
Please take a look at the implementation in Mozilla or Firefox to see the difference.
Created attachment 239343 [details]
Screenshot of Omniweb's Bookmark Separator
I like Omniweb's approach, which is just a plain solid line for the width of the 'label' column, rather than Firefox's dotted line.
Created attachment 241714 [details] [diff] [review]
Fix. It turns out (coincidentally, since I hadn't looked at these screenshots) to look about like comment 7.
Created attachment 241715 [details]
The new .tif for the separator.
Created attachment 241789 [details] [diff] [review]
Trunk project patch
Created attachment 241791 [details] [diff] [review]
Branch project patch
Looks good, Stuart!
Comment on attachment 241714 [details] [diff] [review]
Looks good to me.
+ float fullWidth = [tableColumn width] - 19 - [outlineView indentationPerLevel]*[outlineView levelForItem:item];
+ NSSize imageSize = [mSeparatorImage size];
+ imageSize.width = (fullWidth > 16) ? fullWidth : 16;
any way we can get these magic #s into constants?
Created attachment 241943 [details] [diff] [review]
a less magical version
Comment on attachment 241943 [details] [diff] [review]
a less magical version
Checked in on 1.8branch and trunk.